summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2022-01-16 23:20:44 +0300
committerOrhun Parmaksız2022-01-16 23:20:44 +0300
commita9c4597c77eef61cd651282b59a3aa463c45f00d (patch)
tree3475cc99f226873d4afeac350640016bcc8863f6
parent835b4941f643dfdb50ac72944587e279ad260412 (diff)
downloadaur-a9c4597c77eef61cd651282b59a3aa463c45f00d.tar.gz
upgpkg: menyoki-git 1.5.6.r0.g088e9c2-1
upstream release
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61172c90c846..84783a8c7353 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = menyoki-git
pkgdesc = Screen{shot,cast} and perform ImageOps on the command line (git)
- pkgver = 1.5.5.r0.g7a96353
+ pkgver = 1.5.6.r0.g088e9c2
pkgrel = 1
url = https://github.com/orhun/menyoki
arch = x86_64
license = GPL3
- makedepends = rust
+ makedepends = cargo
makedepends = git
depends = gcc-libs
depends = libxrandr
optdepends = slop: area selection support
provides = menyoki
conflicts = menyoki
+ options = !lto
source = git+https://github.com/orhun/menyoki
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 32637fdd87cb..27b7e2c2b5c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# https://github.com/orhun/pkgbuilds
pkgname=menyoki-git
-pkgver=1.5.5.r0.g7a96353
+pkgver=1.5.6.r0.g088e9c2
pkgrel=1
pkgdesc="Screen{shot,cast} and perform ImageOps on the command line (git)"
arch=('x86_64')
url="https://github.com/orhun/menyoki"
license=('GPL3')
depends=('gcc-libs' 'libxrandr')
-makedepends=('rust' 'git')
+makedepends=('cargo' 'git')
optdepends=('slop: area selection support')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=("git+${url}")
sha512sums=('SKIP')
+options=('!lto')
pkgver() {
cd "${pkgname%-git}"
@@ -23,7 +24,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- cargo fetch --locked
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {