summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-07-06 21:12:16 +0800
committerChocobo12021-07-06 21:12:16 +0800
commitf3ed0100c34fb33e488291ba819da7bac0547d43 (patch)
treed23ea49f9cd2b651417ec3dba8f60c912e9ef874
parent98679bd7f5e2af65989fcf1669b5fe4b5d4a3ba0 (diff)
downloadaur-f3ed0100c34fb33e488291ba819da7bac0547d43.tar.gz
upgpkg: mercurial-hg r47463.5fa083a5ff04-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21bd44c4f5ec..16d8f982493a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mercurial-hg
pkgdesc = Distributed source control management tool
- pkgver = r46486.d7685105e504
+ pkgver = r47463.5fa083a5ff04
pkgrel = 1
url = https://www.mercurial-scm.org/
arch = i686
@@ -16,9 +16,8 @@ pkgbase = mercurial-hg
conflicts = mercurial
backup = etc/mercurial/hgrc
source = hg+https://www.mercurial-scm.org/repo/hg
- source = mercurial.profile::https://git.archlinux.org/svntogit/packages.git/plain/trunk/mercurial.profile?h=packages/mercurial
+ source = mercurial.profile::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/mercurial/trunk/mercurial.profile
sha256sums = SKIP
sha256sums = SKIP
pkgname = mercurial-hg
-
diff --git a/PKGBUILD b/PKGBUILD
index 60dbd6e0e7b2..0dddebcdbb3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=mercurial-hg
-pkgver=r46486.d7685105e504
+pkgver=r47463.5fa083a5ff04
pkgrel=1
pkgdesc="Distributed source control management tool"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ provides=('mercurial')
conflicts=('mercurial')
backup=('etc/mercurial/hgrc')
source=("hg+https://www.mercurial-scm.org/repo/hg"
- "mercurial.profile::https://git.archlinux.org/svntogit/packages.git/plain/trunk/mercurial.profile?h=packages/mercurial")
+ "mercurial.profile::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/mercurial/trunk/mercurial.profile")
sha256sums=('SKIP'
'SKIP')
@@ -28,7 +28,10 @@ pkgver() {
build() {
cd "hg"
- make PURE="--rust" all
+ export PYTHONHASHSEED=0
+ make \
+ PURE="--rust" \
+ all
make -C "contrib/chg"
}
@@ -41,8 +44,16 @@ check() {
package() {
cd "hg"
- make DESTDIR="$pkgdir" PREFIX="/usr" PURE="--rust" install
- make DESTDIR="$pkgdir" PREFIX="/usr" -C "contrib/chg" install
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX="/usr" \
+ PURE="--rust" \
+ install
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX="/usr" \
+ -C "contrib/chg" \
+ install
install -Dm755 contrib/{hgk,hg-ssh} -t "$pkgdir/usr/bin"
install -Dm644 "contrib/bash_completion" "$pkgdir/usr/share/bash-completion/completions/hg"