summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-07-06 21:25:27 +0800
committerChocobo12021-07-06 21:25:27 +0800
commitef6b3bb48600b383e54843c03144989dfe901381 (patch)
tree0025b5f9b332dd58538cf9794b376e7fb25b1eae
parent962c7410d5ebaaf5fbda5d2b1569c80fea9bb832 (diff)
downloadaur-ef6b3bb48600b383e54843c03144989dfe901381.tar.gz
upgpkg: mercurial-stable-hg r47464.25d36300ba8e-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c854a71b7ffd..1ec6238c3032 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mercurial-stable-hg
pkgdesc = Distributed source control management tool (development stable branch)
- pkgver = r46489.fb6eca7b8c63
+ pkgver = r47464.25d36300ba8e
pkgrel = 1
url = https://www.mercurial-scm.org/
arch = i686
@@ -16,9 +16,8 @@ pkgbase = mercurial-stable-hg
conflicts = mercurial
backup = etc/mercurial/hgrc
source = hg+https://www.mercurial-scm.org/repo/hg#branch=stable
- source = mercurial.profile::https://git.archlinux.org/svntogit/packages.git/plain/trunk/mercurial.profile?h=packages/mercurial
+ source = mercurial.profile::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/mercurial/trunk/mercurial.profile
sha256sums = SKIP
sha256sums = SKIP
pkgname = mercurial-stable-hg
-
diff --git a/PKGBUILD b/PKGBUILD
index 9d5516e9ad69..7189dab85912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=mercurial-stable-hg
-pkgver=r46489.fb6eca7b8c63
+pkgver=r47464.25d36300ba8e
pkgrel=1
pkgdesc="Distributed source control management tool (development stable branch)"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ provides=('mercurial')
conflicts=('mercurial')
backup=('etc/mercurial/hgrc')
source=("hg+https://www.mercurial-scm.org/repo/hg#branch=stable"
- "mercurial.profile::https://git.archlinux.org/svntogit/packages.git/plain/trunk/mercurial.profile?h=packages/mercurial")
+ "mercurial.profile::https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/mercurial/trunk/mercurial.profile")
sha256sums=('SKIP'
'SKIP')
@@ -28,7 +28,10 @@ pkgver() {
build() {
cd "hg"
- make PURE="--rust" all
+ export PYTHONHASHSEED=0
+ make \
+ PURE="--rust" \
+ all
make -C "contrib/chg"
}
@@ -41,8 +44,16 @@ check() {
package() {
cd "hg"
- make DESTDIR="$pkgdir" PREFIX="/usr" PURE="--rust" install
- make DESTDIR="$pkgdir" PREFIX="/usr" -C "contrib/chg" install
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX="/usr" \
+ PURE="--rust" \
+ install
+ make \
+ DESTDIR="$pkgdir" \
+ PREFIX="/usr" \
+ -C "contrib/chg" \
+ install
install -Dm755 contrib/{hgk,hg-ssh} -t "$pkgdir/usr/bin"
install -Dm644 "contrib/bash_completion" "$pkgdir/usr/share/bash-completion/completions/hg"