summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-02-09 17:53:04 -0800
committerxiota2024-02-09 17:53:15 -0800
commit8650f897a24fad93cd1db01321f99c5285ea41f9 (patch)
tree71c884fc62e632254225b23206f7fd7e5ee277f8
parent5db68f0226dbbbc68f7fa0cf1e4bcc2212ed3823 (diff)
downloadaur-8650f897a24fad93cd1db01321f99c5285ea41f9.tar.gz
122.0.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD60
-rw-r--r--mercury-browser.install5
-rw-r--r--mercury-browser.sh32
4 files changed, 48 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c67f557b204..d4f87d06aa34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mercury-browser-bin
pkgdesc = Compiler optimized, private Firefox fork
- pkgver = 121.0.1
- pkgrel = 3
+ pkgver = 122.0.2
+ pkgrel = 1
url = https://github.com/Alex313031/Mercury
install = mercury-browser.install
arch = x86_64
@@ -10,18 +10,16 @@ pkgbase = mercury-browser-bin
optdepends = hunspell: Spell checking
optdepends = hyphen: Hyphenation
optdepends = networkmanager: Location detection via available WiFi networks
- noextract = mercury-browser_121.0.1_amd64.deb
+ noextract = mercury-browser_122.0.2_SSE3.deb
options = !emptydirs
options = !strip
- source = mercury-browser_121.0.1_amd64.deb::https://github.com/Alex313031/Mercury/releases/download/v.121.0.1/mercury-browser_121.0.1_amd64.deb
- source = mercury-browser.sh
+ source = mercury-browser_122.0.2_SSE3.deb::https://github.com/Alex313031/Mercury/releases/download/v.122.0.2/mercury-browser_122.0.2_SSE3.deb
sha256sums = SKIP
- sha256sums = f9e17206a6fc510623d34467ece76787741faabe3bdf02a7facd17147e1dd660
pkgname = mercury-browser-bin
depends = alsa-lib
depends = dbus-glib
depends = gtk3
depends = libnotify
- provides = mercury-browser=121.0.1
+ provides = mercury-browser=122.0.2
conflicts = mercury-browser
diff --git a/PKGBUILD b/PKGBUILD
index 5c10781f3630..93ebe403b02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ fi
# basic info
_pkgname="mercury-browser"
pkgname="$_pkgname${_pkgtype:-}"
-pkgver=121.0.1
-pkgrel=3
+pkgver=122.0.2
+pkgrel=1
pkgdesc="Compiler optimized, private Firefox fork"
url="https://github.com/Alex313031/Mercury"
license=('MPL-2.0')
@@ -34,24 +34,17 @@ _main_package() {
options=('!emptydirs' '!strip')
install="$_pkgname.install"
- : ${_dl_filename:=${_pkgname}_${_pkgver:?}_amd64.deb}
+ : ${_dl_filename:=${_pkgname}_${_pkgver:?}_SSE3.deb}
: ${_dl_url:=$url/releases/download/v.$_pkgver/$_dl_filename}
noextract+=("$_dl_filename")
- source=(
- "$_dl_filename"::"$_dl_url"
- "$_pkgname.sh"
- )
- sha256sums=(
- 'SKIP'
- 'f9e17206a6fc510623d34467ece76787741faabe3bdf02a7facd17147e1dd660'
- )
+ source=("$_dl_filename"::"$_dl_url")
+ sha256sums=('SKIP')
}
# common functions
pkgver() {
- printf '%s' \
- "${_pkgver:?}"
+ echo "${_pkgver:?}"
}
prepare() {
@@ -86,6 +79,37 @@ Exec=$_pkgname -private-window
Name=Open With Temporary User Profile
Exec=$_pkgname --temp-profile
END
+
+ install -Dvm644 /dev/stdin "$_pkgname.sh" <<END
+#!/usr/bin/env bash
+
+# check microprocessor architecture level
+if grep -qE '\bpni\b' /proc/cpuinfo ; then
+ _message=''
+ _message+=\$'The fastest Firefox fork on Earth.'
+else
+ _message=''
+ _message+=\$'Your processor does not support SSE3 instructions.\n'
+ _message+=\$'mercury-browser may not work on your computer.'
+fi
+
+# Allow users to override command-line options
+XDG_CONFIG_HOME=\${XDG_CONFIG_HOME:-~/.config}
+_FLAGFILE="\$XDG_CONFIG_HOME/mercury-flags.conf"
+if [[ -f "\$_FLAGFILE" ]]; then
+ _USER_FLAGS=\$(cat "\$_FLAGFILE")
+fi
+
+# display processor support message
+if tty -s ; then
+ echo "\$_message"
+else
+ [ ! -e "\$HOME/.mercury" ] && notify-send -a "mercury-browser" -t 7500 "\$_message"
+fi
+
+# Launch
+exec /opt/mercury-browser/mercury \$_USER_FLAGS "\$@"
+END
}
package() {
@@ -147,11 +171,11 @@ package() {
ln -sf "/usr/bin/$_pkgname" "$pkgdir/opt/$_pkgname/mercury-bin"
# remove unnecessary folders
- \rm -rf "${pkgdir:?}/usr/lib/"
- \rm -rf "${pkgdir:?}/usr/share/doc/"
- \rm -rf "${pkgdir:?}/usr/share/icons"
- \rm -rf "${pkgdir:?}/usr/share/lintian/"
- \rm -rf "${pkgdir:?}/usr/share/man/"
+ \rm -rf "$pkgdir/usr/lib/"
+ \rm -rf "$pkgdir/usr/share/doc/"
+ \rm -rf "$pkgdir/usr/share/icons"
+ \rm -rf "$pkgdir/usr/share/lintian/"
+ \rm -rf "$pkgdir/usr/share/man/"
# fix permissions
chmod -R u+rwX,go+rX,go-w "$pkgdir/"
diff --git a/mercury-browser.install b/mercury-browser.install
index 819d61c1facf..0a96916fff82 100644
--- a/mercury-browser.install
+++ b/mercury-browser.install
@@ -23,12 +23,9 @@ CYAN="${BOLD}$(tput setaf 6)"
WHITE="${BOLD}$(tput setaf 7)"
post_install() {
- if /usr/lib/ld-linux-x86-64.so.2 --help | grep -qsE '^\s+x86-64-v3.*supported.*$' ; then
+ if grep -qE '\bpni\b' /proc/cpuinfo ; then
note1 "Custom flags may be put directly in: ~/.config/mercury-flags.conf"
note2 "The launcher is called: 'mercury-browser'"
- elif grep -qE '\bpni\b' /proc/cpuinfo ; then
- note1 "Your processor does not supports x86-64-v3."
- note2 "You may want to install mercury-browser-sse3-bin instead."
else
note1 "Your processor does not support SSE3 instructions."
note2 "mercury-browser may not work on your computer."
diff --git a/mercury-browser.sh b/mercury-browser.sh
deleted file mode 100644
index ea7e7f01220c..000000000000
--- a/mercury-browser.sh
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/env bash
-
-# check microprocessor architecture level
-if /usr/lib/ld-linux-x86-64.so.2 --help | grep -qsE '^\s+x86-64-v3.*supported.*$' ; then
- _message=''
- _message+=$'The fastest Firefox fork on Earth.'
-elif grep -qE '\bpni\b' /proc/cpuinfo ; then
- _message=''
- _message+=$'Your processor does not support x86-64-v3.\n'
- _message+=$'You may want to use mercury-browser-sse3-bin.'
-else
- _message=''
- _message+=$'Your processor does not support SSE3 instructions.\n'
- _message+=$'mercury-browser may not work on your computer.'
-fi
-
-# Allow users to override command-line options
-XDG_CONFIG_HOME=${XDG_CONFIG_HOME:-~/.config}
-_FLAGFILE="$XDG_CONFIG_HOME/mercury-flags.conf"
-if [[ -f "$_FLAGFILE" ]]; then
- _USER_FLAGS=$(cat "$_FLAGFILE")
-fi
-
-# display processor support message
-if tty -s ; then
- echo "$_message"
-else
- [ ! -e "$HOME/.mercury" ] && notify-send -a "mercury-browser" -t 7500 "$_message"
-fi
-
-# Launch
-exec /opt/mercury-browser/mercury $_USER_FLAGS "$@"