summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-17 11:55:57 -0800
committerxiota2023-11-17 11:55:57 -0800
commit9923fc43e4bbbf4e1e026f8d265311a264fdf777 (patch)
tree47691fcfa47ce568493cec9532e9285115625a4c
parenta49b41ac23220f4be379fc975c61db70e2dd3f54 (diff)
downloadaur-9923fc43e4bbbf4e1e026f8d265311a264fdf777.tar.gz
fix _autoupdate=false
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57dfdc8f083e..e8e60a07513f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,9 @@
# Contributor: Alexey Peschany <archlinux at sandboiii dot xyz>
# options
-if [ -z "$_pkgver" ] ; then
+if [ -z "$_srcinfo" ] ; then
+ : ${_autoupdate:=false}
+elif [ -z "$_pkgver" ] ; then
: ${_autoupdate:=true}
else
: ${_autoupdate:=false}
@@ -38,7 +40,9 @@ _main_package() {
options=('!emptydirs' '!strip')
install="$_pkgname.install"
- _dl_filename="${_pkgname}_${_pkgver:?}_amd64.deb"
+ : ${_dl_filename:=${_pkgname}_${_pkgver:?}_amd64.deb}
+ : ${_dl_url:=$url/releases/download/v.$pkgver/$_dl_filename}
+
noextract+=("$_dl_filename")
source=(
"$_dl_filename"::"$_dl_url"
@@ -106,6 +110,7 @@ _update_version() {
}
_dl_url=$(_get browser_download_url)
+ _dl_filename="${_dl_url##*/}"
_regex='^.*mercury-browser_([0-9\.]+)_.*\.deb.*$'
_pkgver_new=$(