summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Peschany2023-03-22 15:58:47 +0300
committerAlexey Peschany2023-03-22 15:58:47 +0300
commitad8d4fc5a4fba72205eec493ecf2e4455a84c6d4 (patch)
tree8179b30e7c9633d7d96af8615670da34fc91c9c1
downloadaur-ad8d4fc5a4fba72205eec493ecf2e4455a84c6d4.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD58
-rw-r--r--mercury-browser.desktop14
-rw-r--r--mercury-browser.sh2
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef6c38a41ca0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mercury-browser-bin
+ pkgdesc = The fastest Firefox fork on Earth with compiler optimizations and patches from Librewolf, Waterfox, and GNU IceCat.
+ pkgver = 110.0a1
+ pkgrel = 1
+ url = https://github.com/Alex313031/Mercury
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = dbus-glib
+ depends = gtk3
+ depends = libxt
+ depends = nss
+ optdepends = ffmpeg: H264/AAC/MP3 decoding
+ optdepends = hunspell: Spell checking
+ optdepends = hyphen: Hyphenation
+ optdepends = libnotify: Notification integration
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = pulseaudio: Sound
+ optdepends = upower: Battery API
+ source = https://github.com/Alex313031/Mercury/releases/download/v.110.0a1/Mercury-110.0a1.en-US.linux-x86_64.tar.bz2
+ source = mercury-browser.sh
+ source = mercury-browser.desktop
+ sha256sums = 63e327b78b6688b1c0482f4b927027e2d358aa68182cc8eaa8b70d56796d4228
+ sha256sums = 60955647fd96fff4d16dd77278d845c8205b00dcb37fbad3bd3d362aa013602b
+ sha256sums = 8370ee50614115b06e0f8fa96dfbc2db80e2b9ab41368bf9b4ba42fb8ded9982
+
+pkgname = mercury-browser-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fb484136304
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Alexey Peschany <archlinux at sandboiii dot xyz>
+
+_pkgname=mercury-browser
+pkgname=${_pkgname}-bin
+pkgver=110.0a1
+pkgrel=1
+pkgdesc="The fastest Firefox fork on Earth with compiler optimizations and patches from Librewolf, Waterfox, and GNU IceCat."
+arch=('x86_64')
+url="https://github.com/Alex313031/Mercury"
+license=('MPL' 'GPL' 'LGPL')
+depends=('dbus-glib' 'gtk3' 'libxt' 'nss')
+optdepends=('ffmpeg: H264/AAC/MP3 decoding'
+ 'hunspell: Spell checking'
+ 'hyphen: Hyphenation'
+ 'libnotify: Notification integration'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'pulseaudio: Sound'
+ 'upower: Battery API')
+source=("https://github.com/Alex313031/Mercury/releases/download/v.$pkgver/Mercury-$pkgver.en-US.linux-x86_64.tar.bz2"
+ "$_pkgname.sh"
+ "$_pkgname.desktop")
+sha256sums=('63e327b78b6688b1c0482f4b927027e2d358aa68182cc8eaa8b70d56796d4228'
+ '60955647fd96fff4d16dd77278d845c8205b00dcb37fbad3bd3d362aa013602b'
+ '8370ee50614115b06e0f8fa96dfbc2db80e2b9ab41368bf9b4ba42fb8ded9982')
+
+package() {
+ # Create directories
+ msg2 "Creating directory structure..."
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/applications
+ mkdir -p "$pkgdir"/opt
+
+ msg2 "Moving stuff in place..."
+ # Install
+ cp -r Mercury/ "$pkgdir"/opt/$_pkgname
+
+ # Launchers
+ install -m755 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
+ ln -s $_pkgname "$pkgdir"/usr/bin/$pkgname # compatibility
+
+ # Desktops
+ install -m644 *.desktop "$pkgdir"/usr/share/applications/
+
+ # Icons
+ for i in 16x16 32x32 48x48 64x64 128x128; do
+ install -d "$pkgdir"/usr/share/icons/hicolor/$i/apps/
+ ln -s /opt/$_pkgname/browser/chrome/icons/default/default${i/x*}.png \
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/$_pkgname.png
+ done
+
+ # Use system-provided dictionaries
+ #rm -r "$pkgdir"/opt/$_pkgname/dictionaries
+ ln -Ts /usr/share/hunspell "$pkgdir"/opt/$_pkgname/dictionaries
+ ln -Ts /usr/share/hyphen "$pkgdir"/opt/$_pkgname/hyphenation
+
+ # Use system certificates
+ ln -sf /usr/lib/libnssckbi.so "$pkgdir"/opt/$_pkgname/libnssckbi.so
+}
diff --git a/mercury-browser.desktop b/mercury-browser.desktop
new file mode 100644
index 000000000000..4d58aa761f15
--- /dev/null
+++ b/mercury-browser.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Version=1.0
+Name=Mercury Browser
+GenericName=Web Browser
+Comment=The fastest Firefox fork on Earth
+Exec=mercury-browser %u
+Icon=mercury-browser
+Terminal=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
+StartupWMClass=Mercury Browser
+Categories=Network;WebBrowser;
+Keywords=web;browser;internet;
+Actions=new-window;new-private-window;
diff --git a/mercury-browser.sh b/mercury-browser.sh
new file mode 100644
index 000000000000..3f679ed2e49a
--- /dev/null
+++ b/mercury-browser.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /opt/mercury-browser/Mercury-bin --class "Mercury Browser" --name "Mercury Browser" "$@"