summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-09-28 22:54:21 +0200
committerLW-archlinux2019-09-28 22:54:21 +0200
commit97b9a07ff357e3169aa52d8e8d2c81f2069d9431 (patch)
treebb01330ba0230be662c814c1eec5d0a48cae29fb
parent6ddefddc83cf3292ca6ca0a11ee6480bd8057eb9 (diff)
downloadaur-97b9a07ff357e3169aa52d8e8d2c81f2069d9431.tar.gz
switch from extra/libglvnd to aur libglvnd12
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD19
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96b68b63cd88..b37f16e2fa95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 19.3.0_devel.115092.3f5b541fc8b
- pkgrel = 1
+ pkgver = 19.3.0_devel.115749.336b021d36f
+ pkgrel = 2
url = https://www.mesa3d.org
arch = x86_64
license = custom
@@ -22,8 +22,7 @@ pkgbase = mesa-git
makedepends = wayland-protocols
makedepends = meson
makedepends = ninja
- makedepends = llvm=8.0.1
- makedepends = clang=8.0.1
+ makedepends = llvm-minimal-git
depends = libdrm
depends = libxxf86vm
depends = libxdamage
@@ -31,19 +30,19 @@ pkgbase = mesa-git
depends = libelf
depends = libomxil-bellagio
depends = libunwind
- depends = libglvnd
+ depends = libglvnd12
depends = wayland
depends = lm_sensors
depends = libclc
depends = glslang
- depends = llvm-libs=8.0.1
+ depends = llvm-libs-minimal-git
optdepends = opengl-man-pages: for the OpenGL API man pages
- provides = mesa=19.3.0_devel.115092.3f5b541fc8b-1
- provides = vulkan-intel=19.3.0_devel.115092.3f5b541fc8b-1
- provides = vulkan-radeon=19.3.0_devel.115092.3f5b541fc8b-1
- provides = vulkan-mesa-layer=19.3.0_devel.115092.3f5b541fc8b-1
- provides = libva-mesa-driver=19.3.0_devel.115092.3f5b541fc8b-1
- provides = mesa-vdpau=19.3.0_devel.115092.3f5b541fc8b-1
+ provides = mesa=19.3.0_devel.115749.336b021d36f-2
+ provides = vulkan-intel=19.3.0_devel.115749.336b021d36f-2
+ provides = vulkan-radeon=19.3.0_devel.115749.336b021d36f-2
+ provides = vulkan-mesa-layer=19.3.0_devel.115749.336b021d36f-2
+ provides = libva-mesa-driver=19.3.0_devel.115749.336b021d36f-2
+ provides = mesa-vdpau=19.3.0_devel.115749.336b021d36f-2
provides = vulkan-driver
provides = opencl-
provides = opengl-driver
diff --git a/PKGBUILD b/PKGBUILD
index cdb7be59cc4b..7af1c5bfdba2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,14 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=19.3.0_devel.115092.3f5b541fc8b
-pkgrel=1
+pkgver=19.3.0_devel.115749.336b021d36f
+pkgrel=2
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
'ocl-icd' 'vulkan-icd-loader' 'libgcrypt' 'wayland' 'wayland-protocols' 'meson' 'ninja')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
- 'libomxil-bellagio' 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'libclc' 'glslang')
+ 'libomxil-bellagio' 'libunwind' 'libglvnd12' 'wayland' 'lm_sensors' 'libclc' 'glslang')
optdepends=('opengl-man-pages: for the OpenGL API man pages')
provides=(mesa=$pkgver-$pkgrel vulkan-intel=$pkgver-$pkgrel vulkan-radeon=$pkgver-$pkgrel vulkan-mesa-layer=$pkgver-$pkgrel libva-mesa-driver=$pkgver-$pkgrel mesa-vdpau=$pkgver-$pkgrel vulkan-driver opencl- opengl-driver opencl-driver)
conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau')
@@ -130,10 +130,13 @@ build () {
}
package() {
- DESTDIR="$pkgdir" ninja $NINJAFLAGS -C _build install
+ DESTDIR="${pkgdir}" ninja $NINJAFLAGS -C _build install
- # indirect rendering
- ln -s /usr/lib/libGLX_mesa.so.0 ${pkgdir}/usr/lib/libGLX_indirect.so.0
-
- install -Dt "$pkgdir"/usr/share/licenses/$pkgname "$srcdir"/LICENSE
+ # indirect rendering
+ ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}/usr/lib/libGLX_indirect.so.0"
+
+ # remove files provided by libglvnd 1.2.0 and later
+# rm ${pkgdir}/usr/lib/pkgconfig/{e,}gl.pc
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE"
}