summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-07-23 14:56:56 +0200
committerTérence Clastres2019-07-23 15:01:58 +0200
commitc7831b6040630d256106775b8169eda5a3666983 (patch)
tree0e689c96d116cc1fb14a9cdc6398f2a624a88824
parent2e5d748202287c37a8978e4ba2356b536df42e05 (diff)
downloadaur-c7831b604063.tar.gz
Also provide egl.pc
Since https://gitlab.freedesktop.org/mesa/mesa/commit/1a25980c469b38d2c6456344fe538ad1bcb47f63, mesa also got rid of the egl pkgconfig file and expects libglvnd to provide it with the others.
-rw-r--r--.SRCINFO4
-rw-r--r--Add-pkgconfig-data-for-libraries-implemented-so-far.patch42
-rw-r--r--PKGBUILD4
3 files changed, 40 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f851d02c626..a36e3e299c74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libglvnd-glesv2
pkgdesc = The GL Vendor-Neutral Dispatch library patched to add glesv2 and other pkgconfig data removed from mesa 19.1
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/NVIDIA/libglvnd
arch = x86_64
license = custom:BSD-like
@@ -19,7 +19,7 @@ pkgbase = libglvnd-glesv2
source = Add-pkgconfig-data-for-libraries-implemented-so-far.patch
source = LICENSE
sha512sums = f64a481be002b108bc45147f9ecddc97561d09b15dd2fee82e76642f8d298f5b21458042dea3083ade650181d5f937bf550bba2914fbf46a774990abdbc56883
- sha512sums = 761fdccd2d6ee744dd55790b0d76b14263cc554e9ba70705a1cd607d33b8a72c437387039818e6795320e261da2a14eb783dfdbb67f14f6319fe2dbbf9614281
+ sha512sums = ff685ebc716c13d169202fb8ada979c7f5121e3106897886777e8b54ea5fc35358389412bfcc398a4304463108676c3ed295f905ea8c2dedd3d9145ac2b505af
sha512sums = bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5
pkgname = libglvnd-glesv2
diff --git a/Add-pkgconfig-data-for-libraries-implemented-so-far.patch b/Add-pkgconfig-data-for-libraries-implemented-so-far.patch
index 7210af9e9c68..32397560bc43 100644
--- a/Add-pkgconfig-data-for-libraries-implemented-so-far.patch
+++ b/Add-pkgconfig-data-for-libraries-implemented-so-far.patch
@@ -1,8 +1,8 @@
diff --git a/configure.ac b/configure.ac
-index 4a2099a..ca213e1 100644
+index cdbb138..be8fc4e 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -309,9 +309,13 @@ AC_CONFIG_FILES([Makefile
+@@ -324,11 +324,16 @@ AC_CONFIG_FILES([Makefile
include/Makefile
src/Makefile
src/GL/Makefile
@@ -15,7 +15,37 @@ index 4a2099a..ca213e1 100644
+ src/GLX/glx.pc
src/GLX/Makefile
src/EGL/Makefile
++ src/EGL/egl.pc
src/GLdispatch/Makefile
+ src/GLdispatch/vnd-glapi/Makefile
+ src/util/Makefile
+diff --git a/src/EGL/Makefile.am b/src/EGL/Makefile.am
+index 5c036dc..c55c83e 100644
+--- a/src/EGL/Makefile.am
++++ b/src/EGL/Makefile.am
+@@ -106,3 +106,6 @@ g_egldispatchstubs.c : $(GENERATE_DEPS)
+ g_egldispatchstubs.h : $(GENERATE_DEPS)
+ $(AM_V_GEN)$(PYTHON) $(GENERATE_DISPATCH_SCRIPT) header $(GENERATE_LIST_FILES) > $@
+ endif
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = egl.pc
+diff --git a/src/EGL/egl.pc.in b/src/EGL/egl.pc.in
+new file mode 100644
+index 0000000..6ed6933
+--- /dev/null
++++ b/src/EGL/egl.pc.in
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=${prefix}
++libdir=@libdir@
++includedir=@includedir@
++
++Name: egl
++Description: Mesa EGL Library
++Version: @PACKAGE_VERSION@
++Libs: -L${libdir} -lEGL
++Cflags: -I${includedir}
diff --git a/src/GLESv1/Makefile.am b/src/GLESv1/Makefile.am
index d20017d..88e07bc 100644
--- a/src/GLESv1/Makefile.am
@@ -28,7 +58,7 @@ index d20017d..88e07bc 100644
+pkgconfig_DATA = glesv1_cm.pc
diff --git a/src/GLESv1/glesv1_cm.pc.in b/src/GLESv1/glesv1_cm.pc.in
new file mode 100644
-index 0000000..80da789
+index 0000000..c0473e8
--- /dev/null
+++ b/src/GLESv1/glesv1_cm.pc.in
@@ -0,0 +1,10 @@
@@ -54,7 +84,7 @@ index a9c2351..f40e06f 100644
+pkgconfig_DATA = glesv2.pc
diff --git a/src/GLESv2/glesv2.pc.in b/src/GLESv2/glesv2.pc.in
new file mode 100644
-index 0000000..b3ad672
+index 0000000..d72b5ba
--- /dev/null
+++ b/src/GLESv2/glesv2.pc.in
@@ -0,0 +1,10 @@
@@ -80,7 +110,7 @@ index 030836b..0d19674 100644
+pkgconfig_DATA = glx.pc
diff --git a/src/GLX/glx.pc.in b/src/GLX/glx.pc.in
new file mode 100644
-index 0000000..9449d89
+index 0000000..733d4cb
--- /dev/null
+++ b/src/GLX/glx.pc.in
@@ -0,0 +1,10 @@
@@ -106,7 +136,7 @@ index 647d9e4..4b34dd5 100644
+pkgconfig_DATA = opengl.pc
diff --git a/src/OpenGL/opengl.pc.in b/src/OpenGL/opengl.pc.in
new file mode 100644
-index 0000000..81f67fa
+index 0000000..3eb2903
--- /dev/null
+++ b/src/OpenGL/opengl.pc.in
@@ -0,0 +1,10 @@
diff --git a/PKGBUILD b/PKGBUILD
index 81e02cbeeb27..0bb1cfa78e61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libglvnd-glesv2
_pkgname=${pkgname/-glesv2}
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="The GL Vendor-Neutral Dispatch library patched to add glesv2 and other pkgconfig data removed from mesa 19.1"
arch=('x86_64')
url="https://github.com/NVIDIA/libglvnd"
@@ -17,7 +17,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/NVIDIA/libglvnd/archive/v$p
Add-pkgconfig-data-for-libraries-implemented-so-far.patch
LICENSE)
sha512sums=('f64a481be002b108bc45147f9ecddc97561d09b15dd2fee82e76642f8d298f5b21458042dea3083ade650181d5f937bf550bba2914fbf46a774990abdbc56883'
- '761fdccd2d6ee744dd55790b0d76b14263cc554e9ba70705a1cd607d33b8a72c437387039818e6795320e261da2a14eb783dfdbb67f14f6319fe2dbbf9614281'
+ 'ff685ebc716c13d169202fb8ada979c7f5121e3106897886777e8b54ea5fc35358389412bfcc398a4304463108676c3ed295f905ea8c2dedd3d9145ac2b505af'
'bf0f4a7e04220a407400f89226ecc1f798cc43035f2538cc8860e5088e1f84140baf0d4b0b28f66e4b802d4d6925769a1297c24e1ba39c1c093902b2931781a5')
build() {