summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-09-10 16:48:27 +0200
committerLone_Wolf2021-09-10 16:48:27 +0200
commit030eee4e3401e1d6470e2edf881bd91e3080ea03 (patch)
tree1761154d02e0eb00fc0622a8dc30e095b8f894da
parentd596359ca1bf2d4de42134ec4e34612bef5a9c1d (diff)
downloadaur-030eee4e3401e1d6470e2edf881bd91e3080ea03.tar.gz
patch added to solve build failure, see https://gitlab.freedesktop.org/mesa/mesa/-/issues/5320
-rw-r--r--.SRCINFO5
-rw-r--r--12715 - use hasParamAttr instead of hasAttribute.patch24
-rw-r--r--PKGBUILD13
3 files changed, 37 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda27e580bf3..6f7f20b587a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.2.0_devel.142376.c70f45c7596
+ pkgver = 21.3.0_devel.144688.2587fa1570e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -60,9 +60,12 @@ pkgbase = mesa-git
conflicts = vulkan-swrast
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main
source = LICENSE
+ source = 12715 - use hasParamAttr instead of hasAttribute.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
+ md5sums = 87cc71137f5fa8b686ff4f562dbf65d5
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
+ sha512sums = 47886f0916dbf68b5cad7cd6aacfc61955d1352bff9431b0958aa17b0280e18d03b3690be872f10156a1d206560b11cf8835446df82f118ffa138acd551e47b8
pkgname = mesa-git
diff --git a/12715 - use hasParamAttr instead of hasAttribute.patch b/12715 - use hasParamAttr instead of hasAttribute.patch
new file mode 100644
index 000000000000..067141ff4d42
--- /dev/null
+++ b/12715 - use hasParamAttr instead of hasAttribute.patch
@@ -0,0 +1,24 @@
+--- a/src/amd/llvm/ac_llvm_helper.cpp
++++ b/src/amd/llvm/ac_llvm_helper.cpp
+@@ -60,7 +60,7 @@
+ llvm::Argument *A = llvm::unwrap<llvm::Argument>(arg);
+ llvm::AttributeList AS = A->getParent()->getAttributes();
+ unsigned ArgNo = A->getArgNo();
+- return AS.hasAttribute(ArgNo + 1, llvm::Attribute::InReg);
++ return AS.hasParamAttr(ArgNo, llvm::Attribute::InReg);
+ }
+
+
+--- a/src/gallium/frontends/clover/llvm/codegen/common.cpp
++++ b/src/gallium/frontends/clover/llvm/codegen/common.cpp
+@@ -233,8 +233,8 @@ namespace {
+ }
+
+ } else {
+- const bool needs_sign_ext = f.getAttributes().hasAttribute(
+- arg.getArgNo() + 1, ::llvm::Attribute::SExt);
++ const bool needs_sign_ext = f.getAttributes().hasParamAttr(
++ arg.getArgNo(), ::llvm::Attribute::SExt);
+
+ args.emplace_back(module::argument::scalar, arg_api_size,
+ target_size, target_align,
diff --git a/PKGBUILD b/PKGBUILD
index 44b00b157cb0..f0e738759157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.2.0_devel.142376.c70f45c7596
+pkgver=21.3.0_devel.144688.2587fa1570e
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -26,11 +26,14 @@ conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-laye
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main'
- 'LICENSE')
+ 'LICENSE'
+ "12715 - use hasParamAttr instead of hasAttribute.patch")
md5sums=('SKIP'
- '5c65a0fe315dd347e09b1f2826a1df5a')
+ '5c65a0fe315dd347e09b1f2826a1df5a'
+ '87cc71137f5fa8b686ff4f562dbf65d5')
sha512sums=('SKIP'
- '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
+ '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
+ '47886f0916dbf68b5cad7cd6aacfc61955d1352bff9431b0958aa17b0280e18d03b3690be872f10156a1d206560b11cf8835446df82f118ffa138acd551e47b8')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -95,8 +98,10 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
+ patch --directory=mesa --forward --strip=1 --input="${srcdir}/12715 - use hasParamAttr instead of hasAttribute.patch"
}
+
build () {
meson setup mesa _build \
-D b_ndebug=true \