summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2022-08-11 17:09:02 +0200
committerReza Jahanbakhshi2022-08-11 17:09:02 +0200
commit0edb6eaab05f038770c3768cc76bc6527fedafc1 (patch)
tree72f7a5110f79f246f0cf82ec5cb06dade45ff069
parent8c9b5a3a856c5d9401da131068a1c2e5a71c293c (diff)
downloadaur-0edb6eaab05f038770c3768cc76bc6527fedafc1.tar.gz
Gallium Driver d3d12 added.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dbdb9105c1c..a0bcddd77bb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 22.2.0_devel.156171.7bb62d9dd859.d41d8cd98f00b204e9800998ecf8427e
+ pkgver = 22.2.0_devel.157447.cb993654033a.d41d8cd98f00b204e9800998ecf8427e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -18,6 +18,7 @@ pkgbase = mesa-git
makedepends = meson
makedepends = ninja
makedepends = glslang
+ makedepends = directx-headers
makedepends = libclc
makedepends = llvm=14.0.6
makedepends = clang=14.0.6
diff --git a/PKGBUILD b/PKGBUILD
index 4286d517fcde..db9167ad93ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,12 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=22.2.0_devel.156171.7bb62d9dd859.d41d8cd98f00b204e9800998ecf8427e
+pkgver=22.3.0_devel.157974.50e6a80b5ea5.d41d8cd98f00b204e9800998ecf8427e
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libxrandr'
- 'wayland-protocols' 'meson' 'ninja' 'glslang' 'libclc')
+ 'wayland-protocols' 'meson' 'ninja' 'glslang' 'directx-headers' 'libclc')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
'libomxil-bellagio' 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'libclc' 'vulkan-icd-loader' 'zstd' 'expat')
optdepends=('opengl-man-pages: for the OpenGL API man pages')
@@ -116,18 +116,16 @@ prepare() {
build () {
meson setup mesa _build \
-D b_ndebug=true \
- -D buildtype=plain \
- --wrap-mode=nofallback \
- -D prefix=/usr \
- -D sysconfdir=/etc \
-D platforms=x11,wayland \
- -D gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast,virgl,iris,zink,crocus \
+ -D gallium-drivers=r300,r600,radeonsi,nouveau,virgl,svga,swrast,iris,crocus,zink,d3d12 \
-D vulkan-drivers=amd,intel,swrast,virtio-experimental \
+ -D vulkan-layers=device-select,overlay \
-D dri3=enabled \
-D egl=enabled \
-D gallium-extra-hud=true \
-D gallium-nine=true \
-D gallium-omx=bellagio \
+ -D gallium-opencl=icd \
-D gallium-va=enabled \
-D gallium-vdpau=enabled \
-D gallium-xa=enabled \
@@ -142,13 +140,15 @@ build () {
-D lmsensors=enabled \
-D osmesa=true \
-D shared-glapi=enabled \
- -D gallium-opencl=icd \
+ -D microsoft-clc=disabled \
-D valgrind=disabled \
- -D vulkan-layers=device-select,overlay \
-D tools=[] \
-D zstd=enabled \
- -D microsoft-clc=disabled \
- -D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc
+ -D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc \
+ -D buildtype=plain \
+ --wrap-mode=nofallback \
+ -D prefix=/usr \
+ -D sysconfdir=/etc
meson configure _build