summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2018-05-15 16:32:12 +0200
committerLW-archlinux2018-05-15 16:32:12 +0200
commit47eab9a1d6c26990dede439aa95a5235dc0d5957 (patch)
treeab24eaa30d8ca925ff1350e01ef74b0e7bc926aa
parent8f936a8ed1e6e9cc443ecea68b3cd2b914757158 (diff)
downloadaur-47eab9a1d6c26990dede439aa95a5235dc0d5957.tar.gz
removed patch for opencl build failure as it entered master
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--opencl-autotools-Fix-linking-order-for-OpenCL-target.patch17
3 files changed, 5 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 422cb0436436..c3badbb59bf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 18.2.0_devel.102206.c879011c72
- pkgrel = 1
+ pkgver = 18.2.0_devel.102242.dace607245
+ pkgrel = 3
url = http://mesa3d.sourceforge.net
arch = x86_64
license = custom
@@ -49,10 +49,8 @@ pkgbase = mesa-git
conflicts = wayland<1.14.93
source = mesa::git://anongit.freedesktop.org/mesa/mesa
source = LICENSE
- source = opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
- sha512sums = f23e31e902e05f9102fdc3f3c7cc96306e04e297785bdc46f955f668588256c8ebfeb530a47bea9e9fea16f5c4e4e75cc0dceb71b042bed6a17a0ce320e234f1
pkgname = mesa-git
diff --git a/PKGBUILD b/PKGBUILD
index 2c2efe6da6f4..d8d772ae104f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
pkgbase=mesa-git
pkgname=('mesa-git')
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=18.2.0_devel.102206.c879011c72
-pkgrel=1
+pkgver=18.2.0_devel.102242.dace607245
+pkgrel=3
arch=('x86_64')
makedepends=('git' 'python2-mako' 'llvm-svn' 'clang-svn' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio'
@@ -27,16 +27,13 @@ url="http://mesa3d.sourceforge.net"
license=('custom')
source=('mesa::git://anongit.freedesktop.org/mesa/mesa'
'LICENSE'
- 'opencl-autotools-Fix-linking-order-for-OpenCL-target.patch'
)
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- 'f23e31e902e05f9102fdc3f3c7cc96306e04e297785bdc46f955f668588256c8ebfeb530a47bea9e9fea16f5c4e4e75cc0dceb71b042bed6a17a0ce320e234f1')
+)
prepare() {
cd mesa
- # fixes opencl build failure, see https://bugs.freedesktop.org/show_bug.cgi?id=106209 and https://patchwork.freedesktop.org/patch/219763/
- patch -Np1 -i ../opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
autoreconf -vfi
}
diff --git a/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch b/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
deleted file mode 100644
index 5ff91ff2578f..000000000000
--- a/opencl-autotools-Fix-linking-order-for-OpenCL-target.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/gallium/targets/opencl/Makefile.am b/src/gallium/targets/opencl/Makefile.am
-index de68a93ad5..f0e1de7797 100644
---- a/src/gallium/targets/opencl/Makefile.am
-+++ b/src/gallium/targets/opencl/Makefile.am
-@@ -23,11 +23,10 @@ lib@OPENCL_LIBNAME@_la_LIBADD = \
- $(LIBELF_LIBS) \
- $(DLOPEN_LIBS) \
- -lclangCodeGen \
-- -lclangFrontendTool \
- -lclangFrontend \
-+ -lclangFrontendTool \
- -lclangDriver \
- -lclangSerialization \
-- -lclangCodeGen \
- -lclangParse \
- -lclangSema \
- -lclangAnalysis \