summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2021-04-15 15:56:51 +0200
committerReza Jahanbakhshi2021-04-15 15:56:51 +0200
commit561f4a707acee34bcff2dddb9c49473f9cd5659a (patch)
treeb8f157fcbf6b7189ca1c8f9c886368aaa45a4e0e
parentbb79952ae5985b6da85addc372815a34a837d4d2 (diff)
downloadaur-561f4a707acee34bcff2dddb9c49473f9cd5659a.tar.gz
Master just got a fix for building against llvm 12 and later, so the patch for the fixedvectortype is removed.
-rw-r--r--.SRCINFO5
-rw-r--r--0001-clover-llvm13-use-FixedVectorType.patch16
-rw-r--r--PKGBUILD13
3 files changed, 5 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65f85c5aeff1..dc89481ca8dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.1.0_devel.137907.1aeebac4e6b
+ pkgver = 21.2.0_devel.138195.b8403192edd
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -60,13 +60,10 @@ pkgbase = mesa-git
conflicts = vulkan-swrast
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
- source = 0001-clover-llvm13-use-FixedVectorType.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
- md5sums = 5f0620ce35da2d1f80dc1b3c03eafc32
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
- sha512sums = c3a567df69a263c6b87d9c7887464ed03b5a0bf008caf180c45cf50dca3f4710e0eda3e453a7a69b89720e333c33b9aa7da1b7f9c79d72bb76d847b567558d19
pkgname = mesa-git
diff --git a/0001-clover-llvm13-use-FixedVectorType.patch b/0001-clover-llvm13-use-FixedVectorType.patch
deleted file mode 100644
index d3eade097f6a..000000000000
--- a/0001-clover-llvm13-use-FixedVectorType.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --unified --recursive --text mesa.orig/src/gallium/frontends/clover/llvm/metadata.hpp mesa.new/src/gallium/frontends/clover/llvm/metadata.hpp
---- mesa.orig/src/gallium/frontends/clover/llvm/metadata.hpp 2021-02-14 13:15:16.994404651 +0100
-+++ mesa.new/src/gallium/frontends/clover/llvm/metadata.hpp 2021-02-14 13:19:11.096855317 +0100
-@@ -129,7 +129,11 @@
- break;
- }
- if (type->isVectorTy())
-- data += std::to_string(((::llvm::VectorType*)type)->getNumElements());
-+#if LLVM_VERSION_MAJOR >= 13
-+ data += std::to_string(((::llvm::FixedVectorType*)type)->getNumElements());
-+#else
-+ data += std::to_string(((::llvm::VectorType*)type)->getNumElements());
-+#endif
-
- } else {
- ::llvm::raw_string_ostream os { data };
diff --git a/PKGBUILD b/PKGBUILD
index b58f0a77d644..6f0870619341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.1.0_devel.137968.437ed05708e
+pkgver=21.2.0_devel.138224.f601fd635bb
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -26,14 +26,11 @@ conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-laye
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
- 'LICENSE'
- '0001-clover-llvm13-use-FixedVectorType.patch')
+ 'LICENSE')
md5sums=('SKIP'
- '5c65a0fe315dd347e09b1f2826a1df5a'
- '5f0620ce35da2d1f80dc1b3c03eafc32')
+ '5c65a0fe315dd347e09b1f2826a1df5a')
sha512sums=('SKIP'
- '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- 'c3a567df69a263c6b87d9c7887464ed03b5a0bf008caf180c45cf50dca3f4710e0eda3e453a7a69b89720e333c33b9aa7da1b7f9c79d72bb76d847b567558d19')
+ '25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -98,8 +95,6 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
- cd mesa
- patch --forward --strip=1 --input="${srcdir}/0001-clover-llvm13-use-FixedVectorType.patch"
}
build () {