summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2024-06-10 15:16:56 +0200
committerLone_Wolf2024-06-10 15:16:56 +0200
commit6281ebf67840f8ba53a6ab6ec16aef39a3c230bd (patch)
treeead1b6ee55e0b9c3321361afa76653940a3999b3
parent98208e2b0a3e79fbeef801d6380813d8bef20dcf (diff)
downloadaur-6281ebf67840f8ba53a6ab6ec16aef39a3c230bd.tar.gz
added patch to solve build issue, see # https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/29275
-rw-r--r--.SRCINFO5
-rw-r--r--29275.patch33
-rw-r--r--PKGBUILD6
3 files changed, 42 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5825010be9c7..df5cf91ad2fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 24.2.0_devel.188655.894f7f43874.d41d8cd
+ pkgver = 24.2.0_devel.190412.6cde457ab60.cf414e8
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -87,18 +87,21 @@ pkgbase = mesa-git
options = !debug
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main
source = LICENSE
+ source = 29275.patch
source = proc-macro2-1.0.70.tar.gz::https://crates.io/api/v1/crates/proc-macro2/1.0.70/download
source = unicode-ident-1.0.12.tar.gz::https://crates.io/api/v1/crates/unicode-ident/1.0.12/download
source = quote-1.0.33.tar.gz::https://crates.io/api/v1/crates/quote/1.0.33/download
source = syn-2.0.39.tar.gz::https://crates.io/api/v1/crates/syn/2.0.39/download
sha256sums = SKIP
sha256sums = 7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2
+ sha256sums = 0385b5021e47a0e13e2ed5c58f115d29c410e3b3ec28a9795fdc377333779ee0
sha256sums = 39278fbbf5fb4f646ce651690877f89d1c5811a3d4acb27700c1cb3cdb78fd3b
sha256sums = 3354b9ac3fae1ff6755cb6db53683adb661634f67557942dea4facebec0fee4b
sha256sums = 5267fca4496028628a95160fc423a33e8b2e6af8a5302579e322e4b520293cae
sha256sums = 23e78b90f2fcf45d3e842032ce32e3f2d1545ba6636271dcbf24fa306d87be7a
b2sums = SKIP
b2sums = cc60238726b35133b5b729fb4ed1e76e04136588533615d84b4a54656d5b41727d5e7ff06ef4de3eb102eed6669d6c5c5cb8ac9fbdf6fc25aa477877c5c3ba87
+ b2sums = 9c2112e513dfff173f680827764228b07ea9b2fef7c4c63b6287c55b1cb0b4a6ef37a1596dd0bf9a200f3b93c67b27253dd36194d4c73c127fff5bcb35263c6b
b2sums = fff0dec06b21e391783cc136790238acb783780eaedcf14875a350e7ceb46fdc100c8b9e3f09fb7f4c2196c25d4c6b61e574c0dad762d94533b628faab68cf5c
b2sums = 4cede03c08758ccd6bf53a0d0057d7542dfdd0c93d342e89f3b90460be85518a9fd24958d8b1da2b5a09b5ddbee8a4263982194158e171c2bba3e394d88d6dac
b2sums = 77c4b166f1200e1ee2ab94a5014acd334c1fe4b7d72851d73768d491c56c6779a0882a304c1f30c88732a6168351f0f786b10516ae537cff993892a749175848
diff --git a/29275.patch b/29275.patch
new file mode 100644
index 000000000000..5bf357b7c47c
--- /dev/null
+++ b/29275.patch
@@ -0,0 +1,33 @@
+From 34fa84a06de74cfde95faf3e4a0d30922d08601d Mon Sep 17 00:00:00 2001
+From: Karol Herbst <kherbst@redhat.com>
+Date: Fri, 17 May 2024 23:25:12 +0200
+Subject: [PATCH] rusticl/meson: add build root dir to the include dirs of
+ rusticl_c
+
+The static inline wrapper includes the header file relatively from where
+`bindgen` gets executed, or so it seems.
+
+I'm sure we can come up with a better solution, but this unbreaks builds.
+
+Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/11178
+Fixes: 53629b0a2d4 ("rusticl: make use of new `output_inline_wrapper` meson.rust.bindgen feature")
+Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/29275>
+---
+ src/gallium/frontends/rusticl/meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/gallium/frontends/rusticl/meson.build b/src/gallium/frontends/rusticl/meson.build
+index 39b2089fcfc9d..0663a2b6c59a0 100644
+--- a/src/gallium/frontends/rusticl/meson.build
++++ b/src/gallium/frontends/rusticl/meson.build
+@@ -347,6 +347,7 @@ rusticl_c = static_library(
+ ],
+ gnu_symbol_visibility : 'hidden',
+ include_directories : [
++ meson.build_root(),
+ inc_gallium,
+ inc_gallium_aux,
+ inc_include,
+--
+GitLab
+
diff --git a/PKGBUILD b/PKGBUILD
index 68b0dac1e90b..a4dbcfd405fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=24.2.0_devel.188655.894f7f43874.d41d8cd
+pkgver=24.2.0_devel.190412.6cde457ab60.cf414e8
pkgrel=1
arch=('x86_64')
makedepends=(
@@ -91,18 +91,22 @@ conflicts=(
)
url="https://www.mesa3d.org"
license=('custom')
+# https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/29275
source=(
'mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main'
'LICENSE'
+ '29275.patch'
)
sha256sums=('SKIP'
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
+ '0385b5021e47a0e13e2ed5c58f115d29c410e3b3ec28a9795fdc377333779ee0'
'39278fbbf5fb4f646ce651690877f89d1c5811a3d4acb27700c1cb3cdb78fd3b'
'3354b9ac3fae1ff6755cb6db53683adb661634f67557942dea4facebec0fee4b'
'5267fca4496028628a95160fc423a33e8b2e6af8a5302579e322e4b520293cae'
'23e78b90f2fcf45d3e842032ce32e3f2d1545ba6636271dcbf24fa306d87be7a')
b2sums=('SKIP'
'cc60238726b35133b5b729fb4ed1e76e04136588533615d84b4a54656d5b41727d5e7ff06ef4de3eb102eed6669d6c5c5cb8ac9fbdf6fc25aa477877c5c3ba87'
+ '9c2112e513dfff173f680827764228b07ea9b2fef7c4c63b6287c55b1cb0b4a6ef37a1596dd0bf9a200f3b93c67b27253dd36194d4c73c127fff5bcb35263c6b'
'fff0dec06b21e391783cc136790238acb783780eaedcf14875a350e7ceb46fdc100c8b9e3f09fb7f4c2196c25d4c6b61e574c0dad762d94533b628faab68cf5c'
'4cede03c08758ccd6bf53a0d0057d7542dfdd0c93d342e89f3b90460be85518a9fd24958d8b1da2b5a09b5ddbee8a4263982194158e171c2bba3e394d88d6dac'
'77c4b166f1200e1ee2ab94a5014acd334c1fe4b7d72851d73768d491c56c6779a0882a304c1f30c88732a6168351f0f786b10516ae537cff993892a749175848'