summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2021-03-27 17:56:07 +0100
committerReza Jahanbakhshi2021-03-27 17:56:07 +0100
commit76b96176aea12a597fa79559b365b0fc603a0089 (patch)
treef08f33e82f6731d17d48b1de038cc4ee3419f632
parent27652f405bc50c916ad096fb914962ab597938b3 (diff)
downloadaur-76b96176aea12a597fa79559b365b0fc603a0089.tar.gz
PKGBUILD updated to reflect the change in meson vulkan-layers options.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9905bfb0b27a..4b8e6c298143 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.1.0_devel.137126.ba8ddc0c683
+ pkgver = 21.1.0_devel.137129.4b1217146d3
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e083e14638a4..05aaa35119d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.1.0_devel.137126.ba8ddc0c683
+pkgver=21.1.0_devel.137129.4b1217146d3
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -135,8 +135,7 @@ build () {
-D shared-glapi=enabled \
-D gallium-opencl=icd \
-D valgrind=disabled \
- -D vulkan-overlay-layer=true \
- -D vulkan-device-select-layer=true \
+ -D vulkan-layers=device-select,overlay \
-D tools=[] \
-D zstd=enabled \
-D microsoft-clc=disabled
@@ -149,6 +148,11 @@ build () {
package() {
DESTDIR="${pkgdir}" ninja $NINJAFLAGS -C _build install
+ # remove script file from /usr/bin
+ # https://gitlab.freedesktop.org/mesa/mesa/issues/2230
+ rm "${pkgdir}/usr/bin/mesa-overlay-control.py"
+ rmdir "${pkgdir}/usr/bin"
+
# indirect rendering
ln -s /usr/lib/libGLX_mesa.so.0 "${pkgdir}/usr/lib/libGLX_indirect.so.0"