summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-05-03 16:52:32 +0200
committerLW-archlinux2019-05-03 16:52:32 +0200
commit8778bf777eebfcc66054885db0ca4254efe1408a (patch)
tree6225c2a16a29a0eeff4e4821f232527c77c1ffc9
parentf47c39b0cae93143154d7515cc497d9166caf067 (diff)
downloadaur-8778bf777eebfcc66054885db0ca4254efe1408a.tar.gz
switched to NINJAFLAGS
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0fab9424579..30b6fc67bddb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 19.1.0_devel.110426.07745f94948
+ pkgver = 19.1.0_devel.110690.80dc78407d0
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
license = custom
makedepends = git
makedepends = python-mako
- makedepends = llvm-lw-git
makedepends = clang-lw-git
+ makedepends = llvm-lw-git
makedepends = xorgproto
makedepends = libxml2
makedepends = libx11
diff --git a/PKGBUILD b/PKGBUILD
index 0d0300144cd7..18d0b6a72700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,10 @@
pkgbase=mesa-git
pkgname=('mesa-git')
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=19.1.0_devel.110426.07745f94948
+pkgver=19.1.0_devel.110690.80dc78407d0
pkgrel=1
arch=('x86_64')
-makedepends=('git' 'python-mako' 'llvm-lw-git' 'clang-lw-git' 'xorgproto'
+makedepends=('git' 'python-mako' 'clang-lw-git' 'llvm-lw-git' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio' 'libxrandr'
'ocl-icd' 'vulkan-icd-loader' 'libgcrypt' 'wayland' 'wayland-protocols' 'meson')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
@@ -75,10 +75,10 @@ build () {
-D vulkan-overlay-layer=true \
-D tools=[]
meson configure _build
- if [[ ! $MAKEFLAGS ]]; then
- ninja "$MAKEFLAGS" -C _build
+ if [[ ! $NINJAFLAGS ]]; then
+ ninja -C _build
else
- ninja "$MAKEFLAGS" -C _build
+ ninja "$NINJAFLAGS" -C _build
fi
}
@@ -90,5 +90,5 @@ package_mesa-git() {
# indirect rendering
ln -s /usr/lib/libGLX_mesa.so.0 ${pkgdir}/usr/lib/libGLX_indirect.so.0
- install -Dt "$pkgdir"/usr/share/licenses/$pkgbase "$srcdir"/LICENSE
+ install -Dt "$pkgdir"/usr/share/licenses/$pkgname "$srcdir"/LICENSE
}