summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2020-12-11 00:55:05 +0100
committerLone_Wolf2020-12-11 00:55:05 +0100
commitac1bb30188d425f48ef748263dfcf18c741141ae (patch)
tree71fc6262019bc1f341f77b025a51b9d27373d663
parentb2e8d6617b5438e8850cdc7692b42c8fd8aaa3f7 (diff)
downloadaur-ac1bb30188d425f48ef748263dfcf18c741141ae.tar.gz
enabled lavapipe for software based vulkan support
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0432e0f097c5..3e46ac23b3df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -46,6 +46,7 @@ pkgbase = mesa-git
provides = vulkan-mesa-layer
provides = libva-mesa-driver
provides = mesa-vdpau
+ provides = mesa-vulkan
provides = vulkan-driver
provides = opengl-driver
provides = opencl-driver
@@ -56,6 +57,7 @@ pkgbase = mesa-git
conflicts = vulkan-mesa-layer
conflicts = libva-mesa-driver
conflicts = mesa-vdpau
+ conflicts = mesa-vulkan
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d71e618f840c..5ce3e1ba43d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,8 @@ makedepends=('git' 'python-mako' 'xorgproto'
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
'libomxil-bellagio' 'libunwind' 'libglvnd' 'wayland' 'lm_sensors' 'libclc' 'vulkan-icd-loader' 'zstd' 'expat')
optdepends=('opengl-man-pages: for the OpenGL API man pages')
-provides=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau' 'vulkan-driver' 'opengl-driver' 'opencl-driver')
-conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau')
+provides=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau' 'mesa-vulkan' 'vulkan-driver' 'opengl-driver' 'opencl-driver')
+conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-mesa-layer' 'libva-mesa-driver' 'mesa-vdpau' 'mesa-vulkan')
url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
@@ -107,7 +107,7 @@ build () {
-D platforms=x11,wayland \
-D dri-drivers=i915,i965,r200,r100,nouveau \
-D gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast,virgl,iris,zink \
- -D vulkan-drivers=amd,intel \
+ -D vulkan-drivers=amd,intel,swrast \
-D dri3=enabled \
-D egl=enabled \
-D gallium-extra-hud=true \