summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReza Jahanbakhshi2022-03-23 19:20:38 +0100
committerReza Jahanbakhshi2022-03-23 19:20:38 +0100
commitb266aa92567d2aa39b45a2ff7b114fd635fa29f8 (patch)
treebfbe6334e51ff49178f758b0a25919b304e33a0a
parentf43453ad84d00b77c567f0ba8acd34cf36e52552 (diff)
downloadaur-b266aa92567d2aa39b45a2ff7b114fd635fa29f8.tar.gz
clover-common patch is applied upstream.
The patch for the missing include file is added.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--clover-common.patch22
-rw-r--r--missing-include.patch12
4 files changed, 20 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c5fb287fc5c..525d9da4b558 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 22.1.0_devel.150214.eebe298a878.d41d8cd98f00b204e9800998ecf8427e
+ pkgver = 22.1.0_devel.151511.80a29748268.d41d8cd98f00b204e9800998ecf8427e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -62,10 +62,12 @@ pkgbase = mesa-git
conflicts = mesa-libgl
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main
source = LICENSE
- source = clover-common.patch
+ source = missing-include.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
+ md5sums = e0271bc87a5e9f4a39d3f981816555ca
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
+ sha512sums = 2e25cbb6aa5cbe4bef0c4b52cd5ef1104862e763eea19b697e1bb4d8b84680403de7f137195883fa33422f1dbb5d385c9ac762f7202d38b50bbbc3146f1dc5df
pkgname = mesa-git
diff --git a/PKGBUILD b/PKGBUILD
index 819a3dabc590..a5458519119c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=22.1.0_devel.150237.9ef8af357dd.8bc02d9b7565c5f9961ae3bb7f058d35
+pkgver=22.1.0_devel.151511.80a29748268.40c467925f262c73b1da24b1dff22a4e
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -27,13 +27,13 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main'
'LICENSE'
- 'clover-common.patch')
+ 'missing-include.patch')
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- 'd6f0a1dba657afd1f593353c02fe2293')
+ 'e0271bc87a5e9f4a39d3f981816555ca')
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- '6f46745cf78460dece4b3104a244abe2a9b691b22530e4071f00a6f5ed5823b98176ba99855c34afe474f13c6e112371d9ff4e41e2fa58dd8841387c559e86bd')
+ '2e25cbb6aa5cbe4bef0c4b52cd5ef1104862e763eea19b697e1bb4d8b84680403de7f137195883fa33422f1dbb5d385c9ac762f7202d38b50bbbc3146f1dc5df')
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
diff --git a/clover-common.patch b/clover-common.patch
deleted file mode 100644
index ced1113bf3b8..000000000000
--- a/clover-common.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/src/gallium/frontends/clover/llvm/codegen/common.cpp b/src/gallium/frontends/clover/llvm/codegen/common.cpp
-index ff87d9c2a0a..a95da068b1f 100644
---- a/src/gallium/frontends/clover/llvm/codegen/common.cpp
-+++ b/src/gallium/frontends/clover/llvm/codegen/common.cpp
-@@ -203,7 +203,7 @@ namespace {
- // Other types.
- const auto actual_type =
- isa< ::llvm::PointerType>(arg_type) && arg.hasByValAttr() ?
-- cast< ::llvm::PointerType>(arg_type)->getElementType() : arg_type;
-+ cast< ::llvm::PointerType>(arg_type)->getPointerElementType() : arg_type;
-
- if (actual_type->isPointerTy()) {
- const unsigned address_space =
-@@ -214,7 +214,7 @@ namespace {
- static_cast<unsigned>(clang::LangAS::opencl_local);
- if (address_space == map[offset]) {
- const auto pointee_type = cast<
-- ::llvm::PointerType>(actual_type)->getElementType();
-+ ::llvm::PointerType>(actual_type)->getPointerElementType();
- args.emplace_back(binary::argument::local, arg_api_size,
- target_size,
- dl.getABITypeAlignment(pointee_type),
diff --git a/missing-include.patch b/missing-include.patch
new file mode 100644
index 000000000000..060d978ac802
--- /dev/null
+++ b/missing-include.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gallium/frontends/clover/llvm/metadata.hpp b/src/gallium/frontends/clover/llvm/metadata.hpp
+index 578a50c0d21..92548c0f0a3 100644
+--- a/src/gallium/frontends/clover/llvm/metadata.hpp
++++ b/src/gallium/frontends/clover/llvm/metadata.hpp
+@@ -33,6 +33,7 @@
+
+ #include <vector>
+ #include <llvm/Config/llvm-config.h>
++#include <llvm/IR/Constants.h>
+ #include <llvm/IR/Module.h>
+ #include <llvm/IR/Metadata.h>
+