summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLone_Wolf2021-09-14 13:41:42 +0200
committerLone_Wolf2021-09-14 13:41:42 +0200
commitd31d902fd8e17c97a4960ef52a9bfad46025fc27 (patch)
tree8fa7a78d28c33b483c03553d29d6a5409d4e30d8
parent9390e24dda5392c8579aeb858d69eff983f4b9a2 (diff)
downloadaur-d31d902fd8e17c97a4960ef52a9bfad46025fc27.tar.gz
patch included in main and no longer needed, removed
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--use hasParamAttr instead of hasAttribute.patch13
3 files changed, 5 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a851d7305adc..287983b17593 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 21.3.0_devel.144763.3c18e69078a
+ pkgver = 21.3.0_devel.144808.b1eb0887922
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -60,12 +60,9 @@ pkgbase = mesa-git
conflicts = vulkan-swrast
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main
source = LICENSE
- source = use hasParamAttr instead of hasAttribute.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
- md5sums = 5fb1d94f0714863855e0c3d328f02ce4
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
- sha512sums = 4d46d93401efde3be3d879dfb92e3d79453788a87c326968901b1702fd2ba7bda155950b9ce2958320bb0dd6f89b71573610c9f75f809fb5296b9d1355fd1e75
pkgname = mesa-git
diff --git a/PKGBUILD b/PKGBUILD
index 00bba79dc52e..be8eccc27aa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=mesa-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=21.3.0_devel.144763.3c18e69078a
+pkgver=21.3.0_devel.144808.b1eb0887922
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python-mako' 'xorgproto'
@@ -27,13 +27,13 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git#branch=main'
'LICENSE'
- "use hasParamAttr instead of hasAttribute.patch")
+)
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- '5fb1d94f0714863855e0c3d328f02ce4')
+)
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- '4d46d93401efde3be3d879dfb92e3d79453788a87c326968901b1702fd2ba7bda155950b9ce2958320bb0dd6f89b71573610c9f75f809fb5296b9d1355fd1e75')
+)
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -98,7 +98,6 @@ prepare() {
if [ -d _build ]; then
rm -rf _build
fi
- patch --directory=mesa --forward --strip=1 --input="${srcdir}/use hasParamAttr instead of hasAttribute.patch"
}
diff --git a/use hasParamAttr instead of hasAttribute.patch b/use hasParamAttr instead of hasAttribute.patch
deleted file mode 100644
index b9e64f5fb0c7..000000000000
--- a/use hasParamAttr instead of hasAttribute.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/gallium/frontends/clover/llvm/codegen/common.cpp
-+++ b/src/gallium/frontends/clover/llvm/codegen/common.cpp
-@@ -233,8 +233,8 @@ namespace {
- }
-
- } else {
-- const bool needs_sign_ext = f.getAttributes().hasAttribute(
-- arg.getArgNo() + 1, ::llvm::Attribute::SExt);
-+ const bool needs_sign_ext = f.getAttributes().hasParamAttr(
-+ arg.getArgNo(), ::llvm::Attribute::SExt);
-
- args.emplace_back(module::argument::scalar, arg_api_size,
- target_size, target_align,