summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2018-05-26 13:55:35 +0200
committerLW-archlinux2018-05-26 13:55:35 +0200
commite4359950a323c657ebcbf6b7763dd0f3a7dbf8bf (patch)
tree6efb4a5be878f8c232b1ce4998d4f1e764bc35f5
parente277d2a73f3648f6eacf79ed14fa35979b805d51 (diff)
downloadaur-e4359950a323c657ebcbf6b7763dd0f3a7dbf8bf.tar.gz
re-added wayland platform to stay closer to extra/mesa
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8adb234cf01..52a7e4d70248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-git
pkgdesc = an open-source implementation of the OpenGL specification, git version
- pkgver = 18.2.0_devel.102366.6db0660d08
+ pkgver = 18.2.0_devel.102412.79fe00efb4
pkgrel = 1
url = http://mesa3d.sourceforge.net
arch = x86_64
@@ -20,6 +20,8 @@ pkgbase = mesa-git
makedepends = vulkan-icd-loader
makedepends = libgcrypt
makedepends = libclc
+ makedepends = wayland
+ makedepends = wayland-protocols
depends = libdrm
depends = libxxf86vm
depends = libxdamage
@@ -30,6 +32,7 @@ pkgbase = mesa-git
depends = libunwind
depends = libglvnd
depends = libclc
+ depends = wayland
optdepends = opengl-man-pages: for the OpenGL API man pages
provides = mesa
provides = vulkan-intel
@@ -46,7 +49,6 @@ pkgbase = mesa-git
conflicts = vulkan-radeon
conflicts = libva-mesa-driver
conflicts = mesa-vdpau
- conflicts = wayland<1.14.93
source = mesa::git://anongit.freedesktop.org/mesa/mesa
source = LICENSE
source = 1-3-clover-Fix-build-after-llvm-r332881.patch
diff --git a/PKGBUILD b/PKGBUILD
index 1186f5a0cf1f..04f1ffebd18c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,17 +12,17 @@
pkgbase=mesa-git
pkgname=('mesa-git')
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=18.2.0_devel.102366.6db0660d08
+pkgver=18.2.0_devel.102412.79fe00efb4
pkgrel=1
arch=('x86_64')
makedepends=('git' 'python2-mako' 'llvm-svn' 'clang-svn' 'xorgproto'
'libxml2' 'libx11' 'libvdpau' 'libva' 'elfutils' 'libomxil-bellagio'
- 'ocl-icd' 'vulkan-icd-loader' 'libgcrypt' 'libclc')
+ 'ocl-icd' 'vulkan-icd-loader' 'libgcrypt' 'libclc' 'wayland' 'wayland-protocols')
depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'libelf'
- 'libomxil-bellagio' 'llvm-libs-svn' 'libunwind' 'libglvnd' 'libclc')
+ 'libomxil-bellagio' 'llvm-libs-svn' 'libunwind' 'libglvnd' 'libclc' 'wayland')
optdepends=('opengl-man-pages: for the OpenGL API man pages')
provides=('mesa' 'vulkan-intel' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau' 'vulkan-driver' 'opencl-mesa' 'opencl-driver' 'opengl-driver')
-conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau' 'wayland<1.14.93')
+conflicts=('mesa' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'libva-mesa-driver' 'mesa-vdpau')
url="http://mesa3d.sourceforge.net"
license=('custom')
source=('mesa::git://anongit.freedesktop.org/mesa/mesa'
@@ -54,7 +54,7 @@ build () {
--sysconfdir=/etc \
--with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast,virgl \
--with-dri-drivers=i915,i965,r200,radeon,nouveau \
- --with-platforms=x11,drm,surfaceless \
+ --with-platforms=x11,drm,surfaceless,wayland \
--with-vulkan-drivers=intel,radeon \
--enable-texture-float \
--enable-gallium-osmesa \
@@ -119,6 +119,11 @@ package_mesa-git() {
# remove files provided by libglvnd
rm "$pkgdir"/usr/lib/libGLESv{1_CM,2}.so*
+
+ # remove files provided by wayland
+ rm "$pkgdir"/usr/lib/libwayland-egl.so*
+ rm "$pkgdir"/usr/lib/pkgconfig/wayland-egl.pc
+
# indirect rendering
ln -s /usr/lib/libGLX_mesa.so.0 ${pkgdir}/usr/lib/libGLX_indirect.so.0