summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-03-03 21:00:55 -0500
committerVincent Grande2021-03-03 21:00:55 -0500
commit53b08601c46f5d6df85da7f9993983d5e8cc83fe (patch)
tree6c1f8efaed06312fa2378d9140e8d5eb2715044d
parent55a2235d8abbf203a4893c0bf34a8fcedb084b83 (diff)
downloadaur-53b08601c46f5d6df85da7f9993983d5e8cc83fe.tar.gz
remove patch
-rw-r--r--.SRCINFO2
-rw-r--r--8543 clover Fix build with llvm-12.patch42
-rw-r--r--PKGBUILD3
3 files changed, 0 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 684c46909aba..f71c55722d05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -55,12 +55,10 @@ pkgbase = mesa-minimal+-git
conflicts = mesa-vdpau
source = mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git
source = LICENSE
- source = 8543 clover Fix build with llvm-12.patch
source = 0001-clover-llvm13-use-FixedVectorType.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = SKIP
pkgname = mesa-minimal+-git
diff --git a/8543 clover Fix build with llvm-12.patch b/8543 clover Fix build with llvm-12.patch
deleted file mode 100644
index 4c221d544461..000000000000
--- a/8543 clover Fix build with llvm-12.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 67b36d1e81dcdce97daa6eab4a6a7e60c6d3949a Mon Sep 17 00:00:00 2001
-From: Vinson Lee <vlee@freedesktop.org>
-Date: Sat, 16 Jan 2021 22:55:41 -0800
-Subject: [PATCH] clover: Fix build with llvm-12.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Fix build error after LLVM commit c495dfe0268b ("[clang][cli] NFC:
-Decrease the scope of ParseLangArgs parameters").
-
-../src/gallium/frontends/clover/llvm/invocation.cpp: In function ‘std::unique_ptr<clang::CompilerInstance> {anonymous}::create_compiler_instance(const clover::device&, const string&, const std::vector<std::__cxx11::basic_string<char> >&, std::string&)’:
-../src/gallium/frontends/clover/llvm/invocation.cpp:252:55: error: cannot convert ‘clang::PreprocessorOptions’ to ‘std::vector<std::__cxx11::basic_string<char> >&’
- 252 | c->getPreprocessorOpts(),
- | ~~~~~~~~~~~~~~~~~~~~~~^~
- | |
- | clang::PreprocessorOptions
-
-Signed-off-by: Vinson Lee <vlee@freedesktop.org>
----
- src/gallium/frontends/clover/llvm/invocation.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/gallium/frontends/clover/llvm/invocation.cpp b/src/gallium/frontends/clover/llvm/invocation.cpp
-index be0f3976b92..bcbec21cd1c 100644
---- a/src/gallium/frontends/clover/llvm/invocation.cpp
-+++ b/src/gallium/frontends/clover/llvm/invocation.cpp
-@@ -249,7 +249,11 @@ namespace {
-
- c->getInvocation().setLangDefaults(c->getLangOpts(),
- compat::ik_opencl, ::llvm::Triple(target.triple),
-+#if LLVM_VERSION_MAJOR >= 12
-+ c->getPreprocessorOpts().Includes,
-+#else
- c->getPreprocessorOpts(),
-+#endif
- get_language_version(opts, device_clc_version));
-
- c->createDiagnostics(new clang::TextDiagnosticPrinter(
---
-GitLab
-
diff --git a/PKGBUILD b/PKGBUILD
index 7d9693d31a1d..7901140957f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,11 +31,9 @@ url="https://www.mesa3d.org"
license=('custom')
source=('mesa::git+https://gitlab.freedesktop.org/mesa/mesa.git'
'LICENSE'
- '8543 clover Fix build with llvm-12.patch'
'0001-clover-llvm13-use-FixedVectorType.patch')
sha512sums=('SKIP'
'SKIP'
- 'SKIP'
'SKIP')
# ninja grabs all available cores and leaves almost nothing for other processes.
@@ -100,7 +98,6 @@ prepare() {
fi
cd mesa
- patch --forward --strip=1 --input="${srcdir}/8543 clover Fix build with llvm-12.patch"
patch --forward --strip=1 --input="${srcdir}/0001-clover-llvm13-use-FixedVectorType.patch"
}