summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSovietReimu12282022-06-26 18:40:34 +0900
committerSovietReimu12282022-06-26 18:40:34 +0900
commit592cebd161a5d7d5d026bf3421037f251f5d544d (patch)
treeaf3f716dc6a7cb5e9167652fae6567b02780b8f6
parent22adac97a849bd551f4bcda940cd3d563c0a57fa (diff)
downloadaur-592cebd161a5d7d5d026bf3421037f251f5d544d.tar.gz
update version
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD17
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29996e7a8dac..a9a781749d2c 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-rusticl-git
pkgdesc = An open-source implementation of the OpenGL specification, with Rusticl
- pkgver = 22.2.0_devel.153993.93f0ddd51b4.02359b69dbf79b2bb68700002ba384ab
+ pkgver = 22.2.0_devel.156007.99bcfb2c9e8.d41d8cd98f00b204e9800998ecf8427e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -82,14 +82,11 @@ pkgbase = mesa-rusticl-git
conflicts = vulkan-mesa-layer
conflicts = vulkan-mesa
conflicts = mesa-libgl
- source = mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip_nv
+ source = mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip
source = LICENSE
- source = eglapi_hack.patch
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
- md5sums = 83448b54dfea2e53891476fe3d6657e3
sha512sums = SKIP
sha512sums = 25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2
- sha512sums = 2cf8ef08c5ac02e5a795c37a67a12547ab752620b2c2a3f34ff53195f50e1758ebc8004f0b356d99255f2c9af19815e6ac61d66aaebecebe5d1d00578d1f412d
pkgname = mesa-rusticl-git
diff --git a/PKGBUILD b/PKGBUILD
index c8f2c8b8b18c..5c3a0ea78372 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mesa-rusticl-git
pkgdesc="An open-source implementation of the OpenGL specification, with Rusticl"
-pkgver=22.2.0_devel.153993.93f0ddd51b4.02359b69dbf79b2bb68700002ba384ab
+pkgver=22.2.0_devel.156007.99bcfb2c9e8.d41d8cd98f00b204e9800998ecf8427e
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
@@ -26,15 +26,18 @@ conflicts=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vu
'vulkan-mesa-layer' 'vulkan-mesa' 'mesa-libgl')
url="https://www.mesa3d.org"
license=('custom')
-source=('mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip_nv'
+source=('mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip'
'LICENSE'
- 'eglapi_hack.patch')
+# 'eglapi_hack.patch'
+ )
md5sums=('SKIP'
'5c65a0fe315dd347e09b1f2826a1df5a'
- '83448b54dfea2e53891476fe3d6657e3')
+# '83448b54dfea2e53891476fe3d6657e3'
+ )
sha512sums=('SKIP'
'25da77914dded10c1f432ebcbf29941124138824ceecaf1367b3deedafaecabc082d463abcfa3d15abff59f177491472b505bcb5ba0c4a51bb6b93b4721a23c2'
- '2cf8ef08c5ac02e5a795c37a67a12547ab752620b2c2a3f34ff53195f50e1758ebc8004f0b356d99255f2c9af19815e6ac61d66aaebecebe5d1d00578d1f412d')
+# '2cf8ef08c5ac02e5a795c37a67a12547ab752620b2c2a3f34ff53195f50e1758ebc8004f0b356d99255f2c9af19815e6ac61d66aaebecebe5d1d00578d1f412d'
+ )
# NINJAFLAGS is an env var used to pass commandline options to ninja
# NOTE: It's your responbility to validate the value of $NINJAFLAGS. If unsure, don't set it.
@@ -78,12 +81,13 @@ build () {
export CC="clang"
export CXX="clang++"
+ # d3d12 in gallium-drivers is disabled because of build error
meson setup mesa _build \
-D prefix=/usr \
-D sysconfdir=/etc \
-D b_ndebug=true \
-D platforms=auto \
- -D gallium-drivers=r300,r600,radeonsi,nouveau,virgl,svga,swrast,iris,crocus,i915,zink,d3d12 \
+ -D gallium-drivers=r300,r600,radeonsi,nouveau,virgl,svga,swrast,iris,crocus,i915,zink \
-D vulkan-drivers=amd,intel,swrast,virtio-experimental \
-D vulkan-layers=device-select,intel-nullhw,overlay \
-D dri3=enabled \
@@ -111,6 +115,7 @@ build () {
-D gallium-rusticl=true \
-D opencl-spirv=true \
-D shader-cache=enabled \
+ -D rust_std=2021 \
-D c_args="-Wno-error=incompatible-pointer-types-discards-qualifiers"
meson configure _build