summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinLinux10282022-05-15 03:32:48 +0900
committerWinLinux10282022-05-15 03:32:48 +0900
commit77777b71e4fcd16696289389d31c1042d19b4178 (patch)
tree26b65cc2ac882ce37c9878e8a489543459e17a96
parent7d611f75535ed27bd2e5841695ae594738a973ef (diff)
downloadaur-77777b71e4fcd16696289389d31c1042d19b4178.tar.gz
fix PKGBUILD
-rwxr-xr-x[-rw-r--r--].SRCINFO1
-rwxr-xr-x[-rw-r--r--].gitignore0
-rwxr-xr-x[-rw-r--r--]LICENSE0
-rwxr-xr-x[-rw-r--r--]PKGBUILD13
4 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e72d5988e889..5cd4bdabd164 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -55,6 +55,7 @@ pkgbase = mesa-rusticl-git
depends = libglvnd
depends = vulkan-icd-loader
depends = spirv-llvm-translator
+ depends = spirv-tools
optdepends = opencl-headers: headers necessary for OpenCL development
optdepends = opengl-man-pages: for the OpenGL API man pages
optdepends = compiler-rt: opencl
diff --git a/.gitignore b/.gitignore
index d35ed4c56721..d35ed4c56721 100644..100755
--- a/.gitignore
+++ b/.gitignore
diff --git a/LICENSE b/LICENSE
index ae33d2709c44..ae33d2709c44 100644..100755
--- a/LICENSE
+++ b/LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 4e1ed90f1001..15f4ff2802d2 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ depends=('libdrm' 'libxcb' 'wayland' 'python'
'libelf' 'llvm-libs'
'expat'
'libxxf86vm' 'libxdamage' 'libomxil-bellagio' 'libunwind' 'lm_sensors' 'libglvnd' 'vulkan-icd-loader'
- 'spirv-llvm-translator')
+ 'spirv-llvm-translator' 'spirv-tools')
optdepends=('opencl-headers: headers necessary for OpenCL development'
'opengl-man-pages: for the OpenGL API man pages'
'compiler-rt: opencl')
@@ -79,9 +79,9 @@ build () {
-D prefix=/usr \
-D sysconfdir=/etc \
-D b_ndebug=true \
- -D platforms=x11,wayland \
- -D gallium-drivers=r300,r600,radeonsi,nouveau,virgl,svga,swrast,iris,crocus,zink,d3d12 \
- -D vulkan-drivers=amd,intel,swrast \
+ -D platforms=auto \
+ -D gallium-drivers=auto \
+ -D vulkan-drivers=auto \
-D vulkan-layers=device-select,intel-nullhw,overlay \
-D dri3=enabled \
-D egl=enabled \
@@ -91,9 +91,9 @@ build () {
-D gallium-va=enabled \
-D gallium-vdpau=enabled \
-D gallium-xa=enabled \
- -D gallium-xvmc=disabled \
+ -D gallium-xvmc=enabled \
-D gbm=enabled \
- -D gles1=disabled \
+ -D gles1=enabled \
-D gles2=enabled \
-D glvnd=true \
-D glx=dri \
@@ -104,6 +104,7 @@ build () {
-D shared-glapi=enabled \
-D microsoft-clc=disabled \
-D valgrind=enabled \
+ -D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc \
-D gallium-rusticl=true \
-D opencl-spirv=true \
-D shader-cache=enabled \