summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSovietReimu12282022-09-28 02:51:23 +0900
committerSovietReimu12282022-09-28 02:51:23 +0900
commit9a9174b137d672783e0b4a6ec30c33cb25068f0d (patch)
treee0d63a2ca9439c1b34d149a51fbefe208090a0bf
parent48f9f926795e3c85a5d585bb5570e13c8c95f6a0 (diff)
downloadaur-9a9174b137d672783e0b4a6ec30c33cb25068f0d.tar.gz
support radeonsi
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD15
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e510239813e2..687f6c3dd1d6 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mesa-rusticl-git
pkgdesc = An open-source implementation of the OpenGL specification, with Rusticl
- pkgver = 22.3.0_devel.160398.61646022bb5.d41d8cd98f00b204e9800998ecf8427e
+ pkgver = 22.3.0_devel.160570.d1198923d78.d41d8cd98f00b204e9800998ecf8427e
pkgrel = 1
url = https://www.mesa3d.org
arch = x86_64
@@ -56,13 +56,13 @@ pkgbase = mesa-rusticl-git
depends = vulkan-icd-loader
depends = spirv-llvm-translator
depends = spirv-tools
+ depends = vulkan-radeon
optdepends = opencl-headers: headers necessary for OpenCL development
optdepends = opengl-man-pages: for the OpenGL API man pages
optdepends = compiler-rt: opencl
provides = vulkan-mesa-layers
provides = opencl-mesa
provides = vulkan-intel
- provides = vulkan-radeon
provides = vulkan-swrast
provides = libva-mesa-driver
provides = mesa-vdpau
@@ -74,7 +74,6 @@ pkgbase = mesa-rusticl-git
conflicts = vulkan-mesa-layers
conflicts = opencl-mesa
conflicts = vulkan-intel
- conflicts = vulkan-radeon
conflicts = vulkan-swrast
conflicts = libva-mesa-driver
conflicts = mesa-vdpau
@@ -82,7 +81,7 @@ pkgbase = mesa-rusticl-git
conflicts = vulkan-mesa-layer
conflicts = vulkan-mesa
conflicts = mesa-libgl
- source = mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip_radeonsi
+ source = mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip_nv
source = LICENSE
md5sums = SKIP
md5sums = 5c65a0fe315dd347e09b1f2826a1df5a
diff --git a/PKGBUILD b/PKGBUILD
index 09c19ddfabc0..86cdfdd6c3c7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mesa-rusticl-git
pkgdesc="An open-source implementation of the OpenGL specification, with Rusticl"
-pkgver=22.3.0_devel.160398.61646022bb5.d41d8cd98f00b204e9800998ecf8427e
+pkgver=22.3.0_devel.160570.d1198923d78.d41d8cd98f00b204e9800998ecf8427e
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence' 'libxxf86vm'
@@ -10,23 +10,25 @@ makedepends=('python-mako' 'libxml2' 'libx11' 'xorgproto' 'libdrm' 'libxshmfence
'libomxil-bellagio' 'libclc' 'clang' 'libglvnd' 'libunwind' 'lm_sensors' 'libxrandr'
'valgrind' 'glslang' 'vulkan-icd-loader' 'cmake' 'meson'
'rust' 'rust-bindgen' 'directx-headers-git')
+# vulkan-radeonはビルドできないため公式リポジトリのものを使用
depends=('libdrm' 'libxcb' 'wayland' 'python'
'libclc' 'clang'
'libx11' 'libxshmfence' 'zstd'
'libelf' 'llvm-libs'
'expat'
'libxxf86vm' 'libxdamage' 'libomxil-bellagio' 'libunwind' 'lm_sensors' 'libglvnd' 'vulkan-icd-loader'
- 'spirv-llvm-translator' 'spirv-tools')
+ 'spirv-llvm-translator' 'spirv-tools' 'vulkan-radeon')
optdepends=('opencl-headers: headers necessary for OpenCL development'
'opengl-man-pages: for the OpenGL API man pages'
'compiler-rt: opencl')
-provides=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-swrast' 'libva-mesa-driver' 'mesa-vdpau' 'mesa'
+# vulkan-radeonをこのパッケージでビルドできないため、ここから外す
+provides=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-intel' 'vulkan-swrast' 'libva-mesa-driver' 'mesa-vdpau' 'mesa'
'opencl-driver' 'vulkan-driver' 'mesa-libgl' 'opengl-driver')
-conflicts=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-intel' 'vulkan-radeon' 'vulkan-swrast' 'libva-mesa-driver' 'mesa-vdpau' 'mesa'
+conflicts=('vulkan-mesa-layers' 'opencl-mesa' 'vulkan-intel' 'vulkan-swrast' 'libva-mesa-driver' 'mesa-vdpau' 'mesa'
'vulkan-mesa-layer' 'vulkan-mesa' 'mesa-libgl')
url="https://www.mesa3d.org"
license=('custom')
-source=('mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip_radeonsi'
+source=('mesa::git+https://gitlab.freedesktop.org/karolherbst/mesa.git#branch=rusticl/wip_nv'
'LICENSE'
# 'eglapi_hack.patch'
)
@@ -81,13 +83,14 @@ build () {
export CC="clang"
export CXX="clang++"
+ # ビルドできないためvulkan-driversからamdを外す(vulkan-radeon)
meson setup mesa _build \
-D prefix=/usr \
-D sysconfdir=/etc \
-D b_ndebug=true \
-D platforms=auto \
-D gallium-drivers=r300,r600,radeonsi,nouveau,virgl,svga,swrast,iris,crocus,i915,zink,d3d12 \
- -D vulkan-drivers=amd,intel,swrast,virtio-experimental \
+ -D vulkan-drivers=intel,swrast,virtio-experimental \
-D vulkan-layers=device-select,intel-nullhw,overlay \
-D dri3=enabled \
-D egl=enabled \