summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-12-16 04:15:30 -0500
committerTony Lambiris2018-12-16 04:15:30 -0500
commit95562db6f78aca66065bef964c7da0d0cd06f7b9 (patch)
treed38a9093d3566f3e2bf0e04aed92b00889fc727c
downloadaur-95562db6f78aca66065bef964c7da0d0cd06f7b9.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3207423c5bc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mesen-git
+ pkgdesc = A cross-platform NES/Famicom emulator
+ pkgver = 0.9.7
+ pkgrel = 1
+ arch = x86_64
+ license = GPL3
+ makedepends = clang
+ makedepends = gendesk
+ makedepends = zip
+ depends = mono
+ depends = sdl2
+ provides = mesen
+ conflicts = mesen
+ source = Mesen::git+https://github.com/SourMesen/Mesen.git
+ sha256sums = SKIP
+
+pkgname = mesen-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b2070a57dc69
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+Mesen
+*pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c046e9d9582
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=mesen-git
+_pkgname=Mesen
+pkgver=0.9.7
+pkgrel=1
+pkgdesc='A cross-platform NES/Famicom emulator'
+arch=('x86_64')
+makedepends=('clang' 'gendesk' 'zip')
+depends=('mono' 'sdl2')
+conflicts=('mesen')
+provides=('mesen')
+license=('GPL3')
+source=("${_pkgname}::git+https://github.com/SourMesen/Mesen.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Prevent duplicate .desktop from getting created
+ sed -i 's/CreateShortcutFile(desktopFile, mimeTypes);//' GUI.NET/Config/FileAssociationHelper.cs
+
+ gendesk --pkgname "${_pkgname}" --pkgdesc "${pkgdesc}" --exec "/usr/bin/mesen" -n
+
+ # Invoke using mono in a wrapper, since wine (if installed) would open it otherwise
+ cat > "${pkgname}" <<-EOT
+ #!/bin/sh
+ /usr/bin/mono /opt/Mesen/Mesen "\$@"
+ EOT
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname%%-git}"
+ install -Dm644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ cd "${srcdir}/${_pkgname}/GUI.NET/Resources"
+ install -Dm644 "${_pkgname}Icon.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+
+ cd "${srcdir}/${_pkgname}/bin/x64/Release"
+ install -Dm755 "${_pkgname}.exe" "${pkgdir}/opt/${_pkgname}/${_pkgname}"
+
+ cd "${srcdir}/${_pkgname}/InteropDLL/obj.x64"
+ install -Dm644 "lib${_pkgname}Core.x64.dll" "${pkgdir}/usr/lib/lib${_pkgname}Core.dll"
+}