summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorISSOtm2023-01-28 19:27:34 +0100
committerISSOtm2023-01-28 19:27:34 +0100
commit04cec68a199e274a519a0571f7b69e8f9e351277 (patch)
tree7a0037a3a57d702ca82992132429729b072fdd08
downloadaur-04cec68a199e274a519a0571f7b69e8f9e351277.tar.gz
Initial upload: mesen2-git r2260.85b3f1da-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fccf6bfc340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mesen2-git
+ pkgdesc = Multi-system emulator (NES, SNES, Game Boy and PC Engine)
+ pkgver = r2260.85b3f1da
+ pkgrel = 1
+ url = https://www.mesen.ca
+ arch = x86_64
+ license = GPL3
+ makedepends = dotnet-sdk-6.0
+ makedepends = git
+ depends = dotnet-runtime-6.0
+ depends = libevdev
+ depends = sdl2
+ provides = mesen2
+ conflicts = mesen2
+ options = !strip
+ source = mesen2::git+https://github.com/ISSOtm/Mesen2.git#branch=make-gcc-happy
+ sha256sums = SKIP
+
+pkgname = mesen2-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24148da1fe76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Eldred Habert <arch@eldred.fr>
+pkgname=mesen2-git
+pkgver=r2260.85b3f1da
+pkgrel=1
+pkgdesc="Multi-system emulator (NES, SNES, Game Boy and PC Engine)"
+arch=('x86_64')
+url="https://www.mesen.ca"
+license=('GPL3')
+depends=('dotnet-runtime-6.0' 'libevdev' 'sdl2')
+makedepends=('dotnet-sdk-6.0' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=(!strip)
+source=(${pkgname%-git}::'git+https://github.com/ISSOtm/Mesen2.git#branch=make-gcc-happy')
+sha256sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make LTO=true SYSTEM_LIBEVDEV=true STATICLINK=false USE_GCC=true # GCC is part of `base-devel`, `clang` is not.
+ # FIXME: this is currently required because the first build generates two dependency `.so`s
+ # *after* they are necessary.
+ make LTO=true SYSTEM_LIBEVDEV=true STATICLINK=false USE_GCC=true
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/bin/x64/Release/linux-x64/publish"
+ install -Dm 755 Mesen "$pkgdir/usr/bin/${pkgname%-git}"
+}