summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Mensinger2019-10-14 20:32:25 +0200
committerDaniel Mensinger2019-10-14 20:32:25 +0200
commitc3cfefd5d456948846bbf3d53052c3f659a32624 (patch)
tree2d092ccf0e2f995adf09c5c7e0bcbcfc1c3ad5a9
downloadaur-c3cfefd5d456948846bbf3d53052c3f659a32624.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ad2a6b25555
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mesh-git
+ pkgdesc = A memory allocator that automatically reduces the memory footprint of C/C++ applications.
+ pkgver = r942.c5b954e
+ pkgrel = 1
+ url = https://github.com/plasma-umass/Mesh
+ arch = x86_64
+ license = Apache
+ depends = glibc
+ provides = mesh
+ source = mesh-git::git+https://github.com/plasma-umass/Mesh.git
+ source = hlayers::git+https://github.com/emeryberger/Heap-Layers.git
+ source = gtest::git+https://github.com/google/googletest.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = mesh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e053aa291df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Daniel Mensinger <daniel@mensinger-ka.de>
+pkgname=mesh-git
+pkgver=r942.c5b954e
+pkgrel=1
+pkgdesc='A memory allocator that automatically reduces the memory footprint of C/C++ applications. '
+arch=('x86_64')
+url='https://github.com/plasma-umass/Mesh'
+license=('Apache')
+depends=(glibc)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(mesh)
+conflicts=()
+replaces=()
+options=()
+source=("$pkgname::git+https://github.com/plasma-umass/Mesh.git"
+ "hlayers::git+https://github.com/emeryberger/Heap-Layers.git"
+ "gtest::git+https://github.com/google/googletest.git" )
+sha256sums=('SKIP' 'SKIP' 'SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.hlayers.url $srcdir/Heap-Layers
+ git config submodule.gtest.url $srcdir/googletest
+ git submodule update
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ ./configure --optimize
+ make
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/usr/include/plasma"
+ install -c -m 0755 libmesh.so "$pkgdir/usr/lib/libmesh.so"
+ install -c -m 0755 src/plasma/mesh.h "$pkgdir/usr/include/plasma/mesh.h"
+}