summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2024-04-11 19:24:48 +0200
committerbartus2024-04-11 19:26:30 +0200
commit7ac855ece651cd74ad0349873a80932cc3e3ca40 (patch)
tree5a8182846e4d16c600a20adc4a016f538a156438
parent169024ea1fee6e12df62fb22ef67bea1ca7c544d (diff)
downloadaur-meshlab.tar.gz
Fix u3d io plugin rpath
resolve #7
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59e4071280e9..05575f54866e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshlab
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
pkgver = 2023.12
- pkgrel = 3
+ pkgrel = 4
url = https://www.meshlab.net
arch = i686
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = meshlab
makedepends = muparser
makedepends = lib3ds
makedepends = openctm-tools
+ makedepends = patchelf
depends = bzip2
depends = cgal
depends = glew
diff --git a/PKGBUILD b/PKGBUILD
index 76b28446ea80..752d5c8ca124 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,14 @@
pkgname=meshlab
pkgver=2023.12
_pkgver_vcg=${pkgver}
-pkgrel=3
+pkgrel=4
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="https://www.meshlab.net"
license=('GPL2')
depends=('bzip2' 'cgal' 'glew' 'glu' 'openssl' 'qt5-base' 'qt5-declarative' 'qt5-script' 'qt5-xmlpatterns' 'xerces-c'
'gmp' 'mpfr' 'mesa' 'qhull')
-makedepends=('boost' 'cmake' 'eigen' 'ninja' 'git' 'muparser' 'lib3ds' 'openctm-tools')
+makedepends=('boost' 'cmake' 'eigen' 'ninja' 'git' 'muparser' 'lib3ds' 'openctm-tools' 'patchelf')
optdepends=('lib3ds: for Autodesk`s 3D-Studio r3 and r4 .3DS file support'
'muparser: for filer_func plugins'
'openctm-tools: for compressed triangle mesh file format')
@@ -55,6 +55,8 @@ build() {
package() {
DESTDIR="$pkgdir" ninja -C "${srcdir}/build" install
+ # Fix libio_u3d.so missing rpath
+ patchelf --set-rpath '$ORIGIN/../' ${pkgdir}/usr/lib/meshlab/plugins/libio_u3d.so
}
# Generated with git_submodule_PKGBUILD_conf.sh ( https://gist.github.com/bartoszek/41a3bfb707f1b258de061f75b109042b )