summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-07-26 09:01:26 +0200
committerbartus2021-07-26 09:01:26 +0200
commit095832c92505f146d2c29294887c43e87ef24743 (patch)
treebe32392a6790df7e7f9f806b38a0a4abe1cd4cbe
parent992e2603e7ebf738ec7d7c64253ed0c047182b30 (diff)
downloadaur-095832c92505f146d2c29294887c43e87ef24743.tar.gz
Add `cgal` & `openctm` deps
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 661c40c0a671..18258a72b60e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = meshlab
arch = i686
arch = x86_64
license = GPL2
+ makedepends = boost
makedepends = cmake
makedepends = eigen
makedepends = ninja
@@ -14,7 +15,9 @@ pkgbase = meshlab
makedepends = levmar
makedepends = lib3ds
makedepends = mpir
+ makedepends = openctm-tools
depends = bzip2
+ depends = cgal
depends = glew
depends = glu
depends = openssl-1.0
diff --git a/PKGBUILD b/PKGBUILD
index f48767121db2..769713bb33f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,14 @@ pkgdesc="System for processing and editing of unstructured 3D models arising in
arch=('i686' 'x86_64')
url="https://www.meshlab.net"
license=('GPL2')
-depends=('bzip2' 'glew' 'glu' 'openssl-1.0' 'qt5-base' 'qt5-declarative' 'qt5-script' 'qt5-xmlpatterns' 'xerces-c')
-makedepends=('cmake' 'eigen' 'ninja' 'git' 'muparser' 'levmar' 'lib3ds' 'mpir')
+depends=('bzip2' 'cgal' 'glew' 'glu' 'openssl-1.0' 'qt5-base' 'qt5-declarative' 'qt5-script' 'qt5-xmlpatterns' 'xerces-c')
+makedepends=('boost' 'cmake' 'eigen' 'ninja' 'git' 'muparser' 'levmar' 'lib3ds' 'mpir' 'openctm-tools')
optdepends=('u3d: for U3D and IDTF file support'
'lib3ds: for Autodesk`s 3D-Studio r3 and r4 .3DS file support'
'levmar: for isoparametrization and mutualcorrs plugins'
'muparser: for filer_func plugins'
- 'mpir: for Constructive Solid Geometry operation filters')
+ 'mpir: for Constructive Solid Geometry operation filters'
+ 'openctm-tools: for compressed triangle mesh file format')
#also create openctm(aur) jhead-lib structuresynth-lib to handle last dep
source=("$pkgname::git+https://github.com/cnr-isti-vclab/meshlab.git#tag=Meshlab-${pkgver}"
"vcglib::git+https://github.com/cnr-isti-vclab/vcglib.git#tag=${_pkgver_vcg}"