summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-06-21 14:13:47 +0200
committerbartus2017-06-21 14:13:47 +0200
commit53e671bf25afe5ab24cb5cde3107b8350a061c95 (patch)
tree5b9e70eef4fd3e7485f5032195cfd85896e361f3
parent0d03108242e0e7d3526fb63f8ad8115b7e855082 (diff)
downloadaur-53e671bf25afe5ab24cb5cde3107b8350a061c95.tar.gz
fix gcc7 build error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--import_bundle_out.patch38
3 files changed, 47 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b555aa02def..9fa7a7c7e778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshlab
pkgdesc = System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)
pkgver = 2016.12
- pkgrel = 4
+ pkgrel = 5
url = http://www.meshlab.net
install = meshlab.install
arch = i686
@@ -36,6 +36,7 @@ pkgbase = meshlab
source = fix_locale.patch
source = mpir.patch
source = rpath.patch
+ source = import_bundle_out.patch
source = meshlab.desktop
md5sums = SKIP
md5sums = SKIP
@@ -53,6 +54,7 @@ pkgbase = meshlab
md5sums = 5b59b23cf66e42f8b3d3eabe466b3eaa
md5sums = 5df295c21de5bac8d6073528823d975a
md5sums = 78bf780b3353fe212a77eb91db6f6b6c
+ md5sums = 765a59b64dd05b74f6a4bdf3962a1d93
md5sums = 18aed0a21276a22325bf8c32166fb110
pkgname = meshlab
diff --git a/PKGBUILD b/PKGBUILD
index 1618444175b6..b1bec79d2d3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: bartus <aur@bartus.33mail.com>
pkgname=meshlab
pkgver=2016.12
-pkgrel=4
+pkgrel=5
pkgdesc="System for processing and editing of unstructured 3D models arising in 3D scanning (qt5 version)"
arch=('i686' 'x86_64')
url="http://www.meshlab.net"
@@ -27,6 +27,7 @@ source=("git+https://github.com/cnr-isti-vclab/meshlab.git#tag=v2016.12"
"fix_locale.patch"
"mpir.patch"
"rpath.patch"
+ "import_bundle_out.patch"
"meshlab.desktop")
md5sums=('SKIP'
'SKIP'
@@ -44,6 +45,7 @@ md5sums=('SKIP'
'5b59b23cf66e42f8b3d3eabe466b3eaa'
'5df295c21de5bac8d6073528823d975a'
'78bf780b3353fe212a77eb91db6f6b6c'
+ '765a59b64dd05b74f6a4bdf3962a1d93'
'18aed0a21276a22325bf8c32166fb110')
prepare() {
@@ -82,6 +84,9 @@ prepare() {
patch -Np1 -i ../screened_poisson.patch
msg "compile ssynth with -fopenmp flag"
patch -Np1 -i ../ssynth.patch
+ msg "fix bundel/nvm ReadHeader"
+ cd ${srcdir}/vcglib
+ patch -Np1 -i ../import_bundle_out.patch
}
build() {
diff --git a/import_bundle_out.patch b/import_bundle_out.patch
new file mode 100644
index 000000000000..f3afd9a6e36a
--- /dev/null
+++ b/import_bundle_out.patch
@@ -0,0 +1,38 @@
+diff --git a/wrap/io_trimesh/import_nvm.h b/wrap/io_trimesh/import_nvm.h
+index bebe7c36..f797da9d 100644
+--- vcglib/wrap/io_trimesh/import_nvm.h
++++ b/wrap/io_trimesh/import_nvm.h
+@@ -85,14 +85,6 @@ static bool ReadHeader(FILE *fp,unsigned int &num_cams){
+ return true;
+ }
+
+-static bool ReadHeader(const char * filename,unsigned int &/*num_cams*/, unsigned int &/*num_points*/){
+- FILE *fp = fopen(filename, "r");
+- if(!fp) return false;
+- ReadHeader(fp);
+- fclose(fp);
+- return true;
+-}
+-
+
+ static int Open( OpenMeshType &m, std::vector<Shot<ScalarType> > & shots,
+ std::vector<std::string > & image_filenames,
+diff --git a/wrap/io_trimesh/import_out.h b/wrap/io_trimesh/import_out.h
+index 01331bc5..c2cd86fe 100644
+--- vcglib/wrap/io_trimesh/import_out.h
++++ b/wrap/io_trimesh/import_out.h
+@@ -85,14 +85,6 @@ static bool ReadHeader(FILE *fp,unsigned int &num_cams, unsigned int &num_points
+ return true;
+ }
+
+-static bool ReadHeader(const char * filename,unsigned int &/*num_cams*/, unsigned int &/*num_points*/){
+- FILE *fp = fopen(filename, "r");
+- if(!fp) return false;
+- ReadHeader(fp);
+- fclose(fp);
+- return true;
+-}
+-
+
+ static int Open( OpenMeshType &m, std::vector<Shot<ScalarType> > & shots,
+ std::vector<std::string > & image_filenames,