summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChemicalXandco2021-03-01 17:27:37 +0000
committerbartoszek2021-03-10 10:03:18 +0100
commit65f6dd198b6acb702c3018e525f7922aaffe4452 (patch)
tree35000cff1e501931ab05a02dc5049922fd77286e
parented31807e5d342f791904fab1e063e8214308e39c (diff)
downloadaur-65f6dd198b6acb702c3018e525f7922aaffe4452.tar.gz
update to 2021.1.0 and avoid bug in pyside 5.15.2
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
-rw-r--r--pyside_property_error.patch42
4 files changed, 72 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc24c91903b7..ac1526a693b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meshroom
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
- pkgver = 2020.1.1
- pkgrel = 2
+ pkgver = 2021.1.0
+ pkgrel = 1
url = https://alicevision.github.io/
arch = i686
arch = x86_64
@@ -24,14 +24,17 @@ pkgbase = meshroom
depends = qt5-imageformats
depends = qt5-location
depends = qt5-svg
- source = meshroom::git+https://github.com/alicevision/meshroom.git#tag=v2020.1.1
+ depends = qt5-charts
+ source = meshroom::git+https://github.com/alicevision/meshroom.git#tag=v2021.1.0
source = voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git
source = git+https://github.com/alicevision/QtOIIO.git
source = git+https://github.com/alicevision/qmlAlembic.git
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
+ source = pyside_property_error.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc
pkgname = meshroom
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2bdfcc290011
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+meshroom
+qmlAlembic
+QtOIIO
+voctree
+src
diff --git a/PKGBUILD b/PKGBUILD
index f9b77cbc4963..bbba7b3911bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
-fragment="#tag=v2020.1.1"
+fragment="#tag=v2021.1.0"
pkgname=${name}
pkgver=${fragment#\#tag=v}
-pkgrel=2
+pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
license=('MPL2')
groups=()
-_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
+_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg qt5-charts)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision alembic openimageio python python-psutil ${_depends_qt[@]})
makedepends=(git cmake python-{cx_freeze,idna,setuptools})
@@ -19,11 +19,13 @@ source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
+ "pyside_property_error.patch"
)
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc')
prepare() {
cd "${srcdir}"/${pkgname}
@@ -32,6 +34,9 @@ prepare() {
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/cameraSensors.db':g" meshroom/nodes/aliceVision/*.py
sed -i '1 i\#include <cmath>' "${srcdir}"/QtOIIO/src/jetColorMap.hpp
sed -i 's|imageformats|plugins/imageformats|' "${srcdir}"/QtOIIO/src/imageIOHandler/CMakeLists.txt
+
+ # avoid bug in pyside 5.15.2 (https://bugreports.qt.io/browse/PYSIDE-1426)
+ patch -Np1 -i "$srcdir"/pyside_property_error.patch
}
build() {
@@ -39,10 +44,10 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/qt/" -DCMAKE_BUILD_TYPE=Release .
make
- cd "${srcdir}"/qmlAlembic
+ cd "${srcdir}"/qmlAlembic
cmake -DCMAKE_INSTALL_PREFIX="/usr/lib/qt/" -DCMAKE_BUILD_TYPE=Release .
make
-
+
cd "${srcdir}"/${pkgname}
python setup.py build
}
@@ -52,7 +57,7 @@ package() {
cd "${srcdir}"/QtOIIO
make DESTDIR="${pkgdir}" install
- cd "${srcdir}"/qmlAlembic
+ cd "${srcdir}"/qmlAlembic
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/${pkgname}
diff --git a/pyside_property_error.patch b/pyside_property_error.patch
new file mode 100644
index 000000000000..0423594d0764
--- /dev/null
+++ b/pyside_property_error.patch
@@ -0,0 +1,42 @@
+--- meshroom.orig/meshroom/ui/app.py 2021-03-01 16:44:31.268547600 +0000
++++ meshroom/meshroom/ui/app.py 2021-03-01 16:49:33.466725600 +0000
+@@ -284,7 +284,6 @@
+ return md
+ return markdown(md)
+
+- @Property(QJsonValue, constant=True)
+ def systemInfo(self):
+ import platform
+ import sys
+@@ -292,8 +291,8 @@
+ 'platform': '{} {}'.format(platform.system(), platform.release()),
+ 'python': 'Python {}'.format(sys.version.split(" ")[0])
+ }
++ systemInfo = Property(QJsonValue, fget=systemInfo, constant=True)
+
+- @Property("QVariantList", constant=True)
+ def licensesModel(self):
+ """
+ Get info about open-source licenses for the application.
+@@ -315,6 +314,7 @@
+ "onlineUrl": "https://raw.githubusercontent.com/alicevision/AliceVision/develop/COPYING.md"
+ }
+ ]
++ licensesModel = Property("QVariantList", fget=licensesModel, constant=True)
+
+ recentProjectFilesChanged = Signal()
+ recentProjectFiles = Property("QVariantList", _recentProjectFiles, notify=recentProjectFilesChanged)
+--- meshroom.orig/meshroom/ui/reconstruction.py 2021-03-01 16:44:31.313764800 +0000
++++ meshroom/meshroom/ui/reconstruction.py 2021-03-01 16:50:33.238323700 +0000
+@@ -249,10 +249,10 @@
+ self._undistortedImagePath = os.path.join(self._activeNode_PrepareDenseScene.node.output.value, filename)
+ self.denseSceneParamsChanged.emit()
+
+- @Property(type=QObject, constant=True)
+ def attribute(self):
+ """ Get the underlying Viewpoint attribute wrapped by this Viewpoint. """
+ return self._viewpoint
++ attribute = Property(QObject, fget=attribute, constant=True)
+
+ @Property(type="QVariant", notify=initialParamsChanged)
+ def initialIntrinsics(self):