summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-02-10 22:41:59 +0100
committerbartus2020-02-10 22:41:59 +0100
commitcbab9982af60576e71faed7eaaf30193bf1bb05d (patch)
tree84085ed7a5d40cac08c8f3fb7c466ebf049eaa3b
parente4e1dd648eadad1e39cf7dff2084b9e63048d68f (diff)
downloadaur-cbab9982af60576e71faed7eaaf30193bf1bb05d.tar.gz
Override broken `pyside2` with the wheel version.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5204b184607..080cdc5d721e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = meshroom
pkgdesc = Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework.
pkgver = 2019.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://alicevision.github.io/
arch = i686
arch = x86_64
license = MPL2
makedepends = git
makedepends = cmake
+ makedepends = python-pip
+ makedepends = python-psutil
makedepends = python-setuptools
makedepends = python-cx_freeze
depends = alice-vision
depends = alembic
depends = openimageio
- depends = python
- depends = python-psutil
- depends = python-pyside2
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
depends = qt5-3d
diff --git a/PKGBUILD b/PKGBUILD
index 59c7a3ee331a..0c3e76b414c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@ name=meshroom
fragment="#tag=v2019.2.0"
pkgname=${name}
pkgver=${fragment#\#tag=v}
-pkgrel=1
+pkgrel=2
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
license=('MPL2')
groups=()
-_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
+_depends_qt=(qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
-depends=(alice-vision alembic openimageio python python-psutil ${_depends_qt[@]})
-makedepends=(git cmake python-setuptools python-cx_freeze)
+depends=(alice-vision alembic openimageio ${_depends_qt[@]})
+makedepends=(git cmake python-pip python-psutil python-setuptools python-cx_freeze)
source=("${pkgname}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
@@ -44,6 +44,8 @@ build() {
make
cd ${srcdir}/${pkgname}
+ sed -i '/^PySide2/s/5.13.0/5.14.1/' requirements.txt
+ pip install --user -r requirements.txt
python setup.py build
}