summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-06-18 13:13:11 +0200
committerbartus2019-06-18 13:13:11 +0200
commit15d91f4ea9fb08b2f81e4818da573bd64142d46b (patch)
treec6feaa8fafd9fb28eb410ff61a4e9f01fcdcf2a3
parent963dcbae122f1c7f5702cf3133bbdef575c66858 (diff)
downloadaur-15d91f4ea9fb08b2f81e4818da573bd64142d46b.tar.gz
Revert "remove branch name from version string"
This reverts commit 45b46e84ff3b4419dfbcefe633f5133a9e800eeb.
-rw-r--r--PKGBUILD9
-rw-r--r--remove-branch-name-from-version.patch30
2 files changed, 3 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f69342bac383..c646cd5ea482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
fragment="#branch=develop"
pkgname=${name}-git
-pkgver=2019.1.0.r48.ge3d9c6c
+pkgver=2018.1.0.r26.ga110bf9
pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
-url="https://alicevision.github.io/"
+url="http://alicevision.github.io/"
license=('MPL2')
groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
@@ -19,13 +19,11 @@ source=("${name}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
- "remove-branch-name-from-version.patch"
)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '5dc4ee1be284170e943ef7c4492ba3ea')
+ 'SKIP')
pkgver() {
cd "$name"
@@ -40,7 +38,6 @@ prepare() {
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/sensor_width_camera_database.txt':g" meshroom/nodes/aliceVision/*.py
sed -i '1 i\#include <cmath>' ${srcdir}/QtOIIO/src/jetColorMap.hpp
sed -i 's|imageformats|plugins/imageformats|' ${srcdir}/QtOIIO/src/imageIOHandler/CMakeLists.txt
- git apply -v ${srcdir}/remove-branch-name-from-version.patch
}
build() {
diff --git a/remove-branch-name-from-version.patch b/remove-branch-name-from-version.patch
deleted file mode 100644
index 6c2cb8a26bf1..000000000000
--- a/remove-branch-name-from-version.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-commit a9fa35e73bbb84ed754e575ba7f6b7d738cb1edb
-Author: bartus <szczepaniak.bartek+github@gmail.com>
-Date: Thu Jun 13 18:07:30 2019 +0200
-
- Revert "[core] Add git branch name in version name"
-
- This reverts commit 6fc1f09aed23f230da2b889efe015773fd57eaee.
-
-diff --git a/meshroom/__init__.py b/meshroom/__init__.py
-index d91e3c1..8ee42b3 100644
---- a/meshroom/__init__.py
-+++ b/meshroom/__init__.py
-@@ -1,17 +1,6 @@
- __version__ = "2019.1.0"
-
- import os
--scriptPath = os.path.dirname(os.path.abspath( __file__ ))
--headFilepath = os.path.join(scriptPath, "../.git/HEAD")
--# If we are in a release, the git history will not exist.
--# If we are in development, we declare the name of the git development branch in the version name
--if os.path.exists(headFilepath):
-- with open (headFilepath, "r") as headFile:
-- data = headFile.readlines()
-- branchName = data[0].split('/')[-1]
-- # Add git branch name to the Meshroom version name
-- __version__ = __version__ + "-" + branchName
--
- # Allow override from env variable
- __version__ = os.environ.get("REZ_MESHROOM_VERSION", __version__)
-