summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-06-13 18:09:07 +0200
committerbartus2019-06-13 18:22:09 +0200
commit45b46e84ff3b4419dfbcefe633f5133a9e800eeb (patch)
treed484112c19b0c3ace244bf7b49e110aa806d7fb4
parent7d80c96b66a7ca0c22f2a76006a421da3b628e0d (diff)
downloadaur-45b46e84ff3b4419dfbcefe633f5133a9e800eeb.tar.gz
remove branch name from version string
-rw-r--r--PKGBUILD9
-rw-r--r--remove-branch-name-from-version.patch30
2 files changed, 36 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c646cd5ea482..f69342bac383 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@ name=meshroom
#fragment="#commit=9bd70ed8ace83c6dde174178e17c5147bb50248f"
fragment="#branch=develop"
pkgname=${name}-git
-pkgver=2018.1.0.r26.ga110bf9
+pkgver=2019.1.0.r48.ge3d9c6c
pkgrel=1
pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the AliceVision framework."
arch=('i686' 'x86_64')
-url="http://alicevision.github.io/"
+url="https://alicevision.github.io/"
license=('MPL2')
groups=()
_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
@@ -19,11 +19,13 @@ source=("${name}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
+ "remove-branch-name-from-version.patch"
)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '5dc4ee1be284170e943ef7c4492ba3ea')
pkgver() {
cd "$name"
@@ -38,6 +40,7 @@ prepare() {
sed -i "s:'ALICEVISION_SENSOR_DB', '':'ALICEVISION_SENSOR_DB', '/usr/share/aliceVision/sensor_width_camera_database.txt':g" meshroom/nodes/aliceVision/*.py
sed -i '1 i\#include <cmath>' ${srcdir}/QtOIIO/src/jetColorMap.hpp
sed -i 's|imageformats|plugins/imageformats|' ${srcdir}/QtOIIO/src/imageIOHandler/CMakeLists.txt
+ git apply -v ${srcdir}/remove-branch-name-from-version.patch
}
build() {
diff --git a/remove-branch-name-from-version.patch b/remove-branch-name-from-version.patch
new file mode 100644
index 000000000000..6c2cb8a26bf1
--- /dev/null
+++ b/remove-branch-name-from-version.patch
@@ -0,0 +1,30 @@
+commit a9fa35e73bbb84ed754e575ba7f6b7d738cb1edb
+Author: bartus <szczepaniak.bartek+github@gmail.com>
+Date: Thu Jun 13 18:07:30 2019 +0200
+
+ Revert "[core] Add git branch name in version name"
+
+ This reverts commit 6fc1f09aed23f230da2b889efe015773fd57eaee.
+
+diff --git a/meshroom/__init__.py b/meshroom/__init__.py
+index d91e3c1..8ee42b3 100644
+--- a/meshroom/__init__.py
++++ b/meshroom/__init__.py
+@@ -1,17 +1,6 @@
+ __version__ = "2019.1.0"
+
+ import os
+-scriptPath = os.path.dirname(os.path.abspath( __file__ ))
+-headFilepath = os.path.join(scriptPath, "../.git/HEAD")
+-# If we are in a release, the git history will not exist.
+-# If we are in development, we declare the name of the git development branch in the version name
+-if os.path.exists(headFilepath):
+- with open (headFilepath, "r") as headFile:
+- data = headFile.readlines()
+- branchName = data[0].split('/')[-1]
+- # Add git branch name to the Meshroom version name
+- __version__ = __version__ + "-" + branchName
+-
+ # Allow override from env variable
+ __version__ = os.environ.get("REZ_MESHROOM_VERSION", __version__)
+