summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-08-10 16:36:32 +0200
committerbartus2021-08-10 17:02:40 +0200
commita977c10cf920fe49f65f825351f9fb47ea01ef98 (patch)
treed164d4cc6ac799f25446f497aa35587dc788e4cd
parent289051cb7fca882e5304bbaa00e038bc33d6d11f (diff)
downloadaur-a977c10cf920fe49f65f825351f9fb47ea01ef98.tar.gz
Switch to system pyside2 instead of pypi one
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--pyside_property_error.patch42
3 files changed, 53 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55a4205b699a..2217f4ad7b31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = meshroom-git
arch = i686
arch = x86_64
license = MPL2
- makedepends = python-pip
makedepends = git
makedepends = cmake
makedepends = python-setuptools
@@ -17,6 +16,7 @@ pkgbase = meshroom-git
depends = openimageio
depends = python
depends = python-psutil
+ depends = python-pyside2
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
depends = qt5-3d
@@ -28,9 +28,11 @@ pkgbase = meshroom-git
source = voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git
source = git+https://github.com/alicevision/QtOIIO.git
source = git+https://github.com/alicevision/qmlAlembic.git
+ source = pyside_property_error.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc
pkgname = meshroom-git
diff --git a/PKGBUILD b/PKGBUILD
index 6f01862c2870..ba57feb68922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,20 +10,21 @@ pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
license=('MPL2')
-groups=()
-_depends_qt=(qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
+_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision alembic openimageio python python-psutil "${_depends_qt[@]}")
-makedepends=(python-pip git cmake python-setuptools python-cx_freeze patchelf)
+makedepends=(git cmake python-setuptools python-cx_freeze patchelf)
source=("${name}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git"
"git+https://github.com/alicevision/qmlAlembic.git"
+ "pyside_property_error.patch"
)
sha256sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'e211783ead22d388c72f60bac7ab95d670a4d6ae196225c15038b5c9e7c80fdc')
pkgver() {
cd "$name"
@@ -44,6 +45,9 @@ prepare() {
sed -i '/find_package(IlmBase REQUIRED)/d' "${srcdir}"/qmlAlembic/CMakeLists.txt
sed -i 's|ILMBASE_INCLUDE_DIR||' "${srcdir}"/qmlAlembic/src/CMakeLists.txt
rm -rf "${srcdir}"/qmlAlembic/cmake/
+
+ # avoid bug in pyside 5.15.2 (https://bugreports.qt.io/browse/PYSIDE-1426)
+ patch -Np1 -i "$srcdir"/pyside_property_error.patch
}
build() {
@@ -59,8 +63,6 @@ build() {
msg2 'build Meshroom'
cd "${srcdir}"/${name}
- sed -i '/^PySide2/s/5.14.1/5.15.2/' requirements.txt
- pip install --user -r requirements.txt
python setup.py build
}
diff --git a/pyside_property_error.patch b/pyside_property_error.patch
new file mode 100644
index 000000000000..0423594d0764
--- /dev/null
+++ b/pyside_property_error.patch
@@ -0,0 +1,42 @@
+--- meshroom.orig/meshroom/ui/app.py 2021-03-01 16:44:31.268547600 +0000
++++ meshroom/meshroom/ui/app.py 2021-03-01 16:49:33.466725600 +0000
+@@ -284,7 +284,6 @@
+ return md
+ return markdown(md)
+
+- @Property(QJsonValue, constant=True)
+ def systemInfo(self):
+ import platform
+ import sys
+@@ -292,8 +291,8 @@
+ 'platform': '{} {}'.format(platform.system(), platform.release()),
+ 'python': 'Python {}'.format(sys.version.split(" ")[0])
+ }
++ systemInfo = Property(QJsonValue, fget=systemInfo, constant=True)
+
+- @Property("QVariantList", constant=True)
+ def licensesModel(self):
+ """
+ Get info about open-source licenses for the application.
+@@ -315,6 +314,7 @@
+ "onlineUrl": "https://raw.githubusercontent.com/alicevision/AliceVision/develop/COPYING.md"
+ }
+ ]
++ licensesModel = Property("QVariantList", fget=licensesModel, constant=True)
+
+ recentProjectFilesChanged = Signal()
+ recentProjectFiles = Property("QVariantList", _recentProjectFiles, notify=recentProjectFilesChanged)
+--- meshroom.orig/meshroom/ui/reconstruction.py 2021-03-01 16:44:31.313764800 +0000
++++ meshroom/meshroom/ui/reconstruction.py 2021-03-01 16:50:33.238323700 +0000
+@@ -249,10 +249,10 @@
+ self._undistortedImagePath = os.path.join(self._activeNode_PrepareDenseScene.node.output.value, filename)
+ self.denseSceneParamsChanged.emit()
+
+- @Property(type=QObject, constant=True)
+ def attribute(self):
+ """ Get the underlying Viewpoint attribute wrapped by this Viewpoint. """
+ return self._viewpoint
++ attribute = Property(QObject, fget=attribute, constant=True)
+
+ @Property(type="QVariant", notify=initialParamsChanged)
+ def initialIntrinsics(self):