summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-08-10 16:59:53 +0200
committerbartus2021-08-10 17:02:40 +0200
commitb4a3391084bde1ce0ac4cf680a13e96527282665 (patch)
treed2ef07bbccfaee8ebecbdbce0fdae1d6c8052985
parent9ed1eb02036348a7ecb86716be8c14732f040c8b (diff)
downloadaur-b4a3391084bde1ce0ac4cf680a13e96527282665.tar.gz
Add missing deps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bf235285ae0..ee9582c3f3bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,9 @@ pkgbase = meshroom-git
license = MPL2
makedepends = git
makedepends = cmake
- makedepends = python-setuptools
makedepends = python-cx-freeze-qfix
+ makedepends = python-idna
+ makedepends = python-setuptools
makedepends = patchelf
depends = alice-vision-git
depends = alembic
@@ -24,6 +25,7 @@ pkgbase = meshroom-git
depends = qt5-imageformats
depends = qt5-location
depends = qt5-svg
+ depends = qt5-charts
provides = meshroom=2021.1.0
conflicts = meshroom
source = meshroom::git+https://github.com/alicevision/meshroom.git#branch=develop
diff --git a/PKGBUILD b/PKGBUILD
index 37cba00479d7..c301fd00a911 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@ pkgdesc="Meshroom is a free, open-source 3D Reconstruction Software based on the
arch=('i686' 'x86_64')
url="https://alicevision.github.io/"
license=('MPL2')
-_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg)
provides=(${name}=${pkgver%.r*})
conflicts=(${name})
+_depends_qt=(python-pyside2 qt5-quickcontrols{,2} qt5-3d qt5-graphicaleffects qt5-imageformats qt5-location qt5-svg qt5-charts)
#_depends_qt+=(qt5-datavis3d qt5-scxml)
depends=(alice-vision-git alembic openimageio python python-psutil "${_depends_qt[@]}")
-makedepends=(git cmake python-setuptools python-cx_freeze-qfix patchelf)
+makedepends=(git cmake python-{cx-freeze-qfix,idna,setuptools} patchelf)
source=("${name}::git+https://github.com/alicevision/meshroom.git${fragment}"
"voctree::git+https://gitlab.com/alicevision/trainedVocabularyTreeData.git"
"git+https://github.com/alicevision/QtOIIO.git#branch=develop"