summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-04-08 17:46:45 +0200
committerMichael Laß2023-04-08 17:48:48 +0200
commit5c685d3c9663b59dd56620f49e3e223fc714a95f (patch)
treef3237832faabc87c08f7853a863068ad01fddabc
parent7e9a589852b11e73271716cc88c8bea69bfc90c7 (diff)
downloadaur-5c685d3c9663b59dd56620f49e3e223fc714a95f.tar.gz
Update to 2.1.5
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7757bdd08a68..fcdba76da322 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meshtastic-python
pkgdesc = Python CLI and API for talking to Meshtastic devices
- pkgver = 2.1.1
+ pkgver = 2.1.5
pkgrel = 1
url = https://github.com/meshtastic/python/
arch = any
@@ -15,10 +15,11 @@ pkgbase = meshtastic-python
depends = python-pygatt
depends = python-setuptools
depends = python-enum-compat
+ depends = python-requests
optdepends = python-pytap2: TUN tunnel support
- source = https://github.com/meshtastic/python/archive/refs/tags/2.1.1.tar.gz
- source = https://github.com/meshtastic/python/commit/1b372fca8d48609d91419b51da3acc64c2f059f2.patch
- sha256sums = 5a08c4c5d4ee6dffb9fb0162ea6f7fc5cb43dc5f8fe3034afbb5766a7924f3d6
- sha256sums = 4fff826867780036f7f816178852fb837c315de45b757554c4c7775b52a137a1
+ source = https://github.com/meshtastic/python/archive/refs/tags/2.1.5.tar.gz
+ source = https://github.com/meshtastic/python/commit/fc768fa3ea929dc1ca668f6d1a2cc66940650333.patch
+ sha256sums = c78b37f7d9db3311ddff6d11c460acb127b8143e87941f0f09fd1538492fed82
+ sha256sums = eb5c43ae3c3d8dbca9bd96d13107e044184b0d4455eeae87c890e87e0be3f22a
pkgname = meshtastic-python
diff --git a/PKGBUILD b/PKGBUILD
index 383f76a59b2c..930b8c006972 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgname=meshtastic-python
_name=python
-_verbump=1b372fca8d48609d91419b51da3acc64c2f059f2
-pkgver=2.1.1
+_verbump=fc768fa3ea929dc1ca668f6d1a2cc66940650333
+pkgver=2.1.5
pkgrel=1
pkgdesc="Python CLI and API for talking to Meshtastic devices"
arch=('any')
@@ -15,12 +15,12 @@ url="https://github.com/meshtastic/python/"
# https://github.com/meshtastic/python/issues/422
license=('GPL3')
-depends=('python-protobuf' 'python-pypubsub' 'python-dotmap' 'python-pyqrcode' 'python-tabulate' 'python-timeago' 'python-pyyaml' 'python-pygatt' 'python-setuptools' 'python-enum-compat')
+depends=('python-protobuf' 'python-pypubsub' 'python-dotmap' 'python-pyqrcode' 'python-tabulate' 'python-timeago' 'python-pyyaml' 'python-pygatt' 'python-setuptools' 'python-enum-compat' 'python-requests')
optdepends=('python-pytap2: TUN tunnel support')
source=("https://github.com/meshtastic/python/archive/refs/tags/${pkgver}.tar.gz"
"https://github.com/meshtastic/python/commit/${_verbump}.patch")
-sha256sums=('5a08c4c5d4ee6dffb9fb0162ea6f7fc5cb43dc5f8fe3034afbb5766a7924f3d6'
- '4fff826867780036f7f816178852fb837c315de45b757554c4c7775b52a137a1')
+sha256sums=('c78b37f7d9db3311ddff6d11c460acb127b8143e87941f0f09fd1538492fed82'
+ 'eb5c43ae3c3d8dbca9bd96d13107e044184b0d4455eeae87c890e87e0be3f22a')
prepare() {
cd "$_name-$pkgver"