summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsyne2016-10-17 13:49:54 +0300
committersyne2016-10-17 13:49:54 +0300
commitc0debecb89e65cb3840eb61d4f77862e32476c50 (patch)
tree3c5f5cc12d0bfb11f390a8ce310313532f737d8d
parent541b1aabf7f3192c49055e26924dceba16b4a69f (diff)
downloadaur-c0debecb89e65cb3840eb61d4f77862e32476c50.tar.gz
Updated the additional files, all should be in order now
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--mesquite.desktop2
-rw-r--r--mesquite.sh8
4 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4dec94f874c..a1d60ffc603b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mesquite
pkgdesc = A modular, extendible software for evolutionary biology, designed to help biologists organize and analyze comparative data about organisms
pkgver = 3.10
- pkgrel = 1
+ pkgrel = 2
url = http://mesquiteproject.wikispaces.com
arch = any
license = (L)GPL
diff --git a/PKGBUILD b/PKGBUILD
index fc413d664ffe..f4f1b0ea954c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
+# Maintainer: syne <madlikene at aim dot com>
# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
# Contributor: Mick Elliot <micke at sfu dot ca>
-# Maintainer: syne <madlikene at aim dot com>
pkgname=mesquite
pkgver=3.10
_pkgver=310-Linux
buildver=build-765
-pkgrel=1
+pkgrel=2
pkgdesc="A modular, extendible software for evolutionary biology, designed to help biologists organize and analyze comparative data about organisms"
arch=('any')
url="http://mesquiteproject.wikispaces.com"
diff --git a/mesquite.desktop b/mesquite.desktop
index f375a66912f2..a8390d36f585 100644
--- a/mesquite.desktop
+++ b/mesquite.desktop
@@ -2,7 +2,7 @@
Type=Application
Version=1.0
Name=Mesquite
-Comment=A software package for evolutionary biology, designed to analyze comparative data about organisms
+Comment=A modular, extendible software for evolutionary biology, designed to help biologists organize and analyze comparative data about organisms.
Exec=mesquite
Icon=mesquite
Terminal=false
diff --git a/mesquite.sh b/mesquite.sh
index d12e2181fd84..cdf631a38de2 100644
--- a/mesquite.sh
+++ b/mesquite.sh
@@ -1,4 +1,8 @@
#!/bin/sh
+java=/usr/bin/java
+dir=/usr/share/mesquite
+
+cp -r "$dir/../Resources/com/"* "$dir/com/" >& /dev/null
+$java -Djava.library.path=lib -Djri.ignore.ule="yes" -cp "$dir" mesquite.Mesquite $*
+
-cd /usr/share/mesquite
-"$JAVA_HOME/bin/java" -Djava.library.path=lib -Djri.ignore.ule="yes" -cp . mesquite.Mesquite "$@"