summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2015-06-22 23:56:08 +0200
committerUffe Jakobsen2015-06-22 23:56:08 +0200
commita85e52f574cbc1436bebdf70a94327d916ddb5e0 (patch)
treef8789b02e55b056d7b1b206c03b14b48dd5dec50
downloadaur-a85e52f574cbc1436bebdf70a94327d916ddb5e0.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD153
-rw-r--r--mess822-conf-cc.patch7
3 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b1dd139f063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mess822
+ pkgdesc = mess822 is a library for parsing Internet mail messages works wellwith qmail
+ pkgver = 0.58
+ pkgrel = 1
+ url = http://cr.yp.to/mess822.html
+ arch = i686,
+ arch = x86_64
+ license = unknown
+ source = http://cr.yp.to/software/mess822-0.58.tar.gz
+ source = mess822-conf-cc.patch
+ md5sums = 8ce4c29c994a70dcaa30140601213dbe
+ md5sums = 240fb4d711016ee9a4637fe6619d14dc
+
+pkgname = mess822
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c664a687182d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,153 @@
+# PKGBUILD for mess822
+# Contributor: Uffe Jakobsen <uffe@uffe.org>
+# Maintainer: Uffe Jakobsen <uffe@uffe.org>
+pkgname=mess822
+pkgver=0.58
+pkgrel=1
+epoch=
+pkgdesc="mess822 is a library for parsing Internet mail messages works wellwith qmail"
+arch=('i686', 'x86_64')
+url="http://cr.yp.to/mess822.html"
+license=('unknown')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(http://cr.yp.to/software/$pkgname-$pkgver.tar.gz
+ mess822-conf-cc.patch)
+noextract=()
+md5sums=('8ce4c29c994a70dcaa30140601213dbe'
+ '240fb4d711016ee9a4637fe6619d14dc')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 -i "$srcdir/mess822-conf-cc.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make default
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ #make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ #make DESTDIR="$pkgdir/" install
+
+ mkdir "$pkgdir/usr"
+ chmod 755 "$pkgdir/usr"
+
+ mkdir "$pkgdir/usr/lib"
+ chmod 755 "$pkgdir/usr/lib"
+ for f in mess822.a
+ do
+ cp "$f" "$pkgdir/usr/lib/$f"
+ chmod 644 "$pkgdir/usr/lib/$f"
+ done
+
+ mkdir "$pkgdir/usr/include"
+ chmod 755 "$pkgdir/usr/include"
+ for f in mess822.h
+ do
+ cp "$f" "$pkgdir/usr/include/$f"
+ chmod 644 "$pkgdir/usr/include/$f"
+ done
+
+ mkdir "$pkgdir/usr/bin"
+ chmod 755 "$pkgdir/usr/bin"
+ for f in ofmipd ofmipname iftocc new-inject 822field 822header 822date 822received 822print
+ do
+ cp "$f" "$pkgdir/usr/bin/$f"
+ chmod 644 "$pkgdir/usr/bin/$f"
+ done
+
+ mkdir "$pkgdir/usr/man"
+ chmod 755 "$pkgdir/usr/man"
+
+ mkdir "$pkgdir/usr/man/man1"
+ chmod 755 "$pkgdir/usr/man/man1"
+ for f in iftocc.1 new-inject.1 822field.1 822header.1 822date.1 822received.1 822print.1
+ do
+ cp "$f" "$pkgdir/usr/man/man1/$f"
+ chmod 644 "$pkgdir/usr/man/man1/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/man5"
+ chmod 755 "$pkgdir/usr/man/man5"
+ for f in rewriting.5
+ do
+ cp "$f" "$pkgdir/usr/man/man5/$f"
+ chmod 644 "$pkgdir/usr/man/man5/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/man8"
+ chmod 755 "$pkgdir/usr/man/man8"
+ for f in ofmipd.8 ofmipname.8
+ do
+ cp "$f" "$pkgdir/usr/man/man8/$f"
+ chmod 644 "$pkgdir/usr/man/man8/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/man3"
+ chmod 755 "$pkgdir/usr/man/man3"
+ for f in mess822.3 mess822_addr.3 mess822_date.3 mess822_fold.3 mess822_quote.3 mess822_token.3 mess822_when.3
+ do
+ cp "$f" "$pkgdir/usr/man/man3/$f"
+ chmod 644 "$pkgdir/usr/man/man3/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/cat1"
+ chmod 755 "$pkgdir/usr/man/cat1"
+ for f in iftocc.0 new-inject.0 822field.0 822header.0 822date.0 822received.0 822print.0
+ do
+ cp "$f" "$pkgdir/usr/man/cat1/$f"
+ chmod 644 "$pkgdir/usr/man/cat1/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/cat5"
+ chmod 755 "$pkgdir/usr/man/cat5"
+ for f in rewriting.0
+ do
+ cp "$f" "$pkgdir/usr/man/cat5/$f"
+ chmod 644 "$pkgdir/usr/man/cat5/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/cat8"
+ chmod 755 "$pkgdir/usr/man/cat8"
+ for f in ofmipd.0 ofmipname.0;
+ do
+ cp "$f" "$pkgdir/usr/man/cat8/$f"
+ chmod 644 "$pkgdir/usr/man/cat8/$f"
+ done
+
+ mkdir "$pkgdir/usr/man/cat3"
+ chmod 755 "$pkgdir/usr/man/cat3"
+ for f in mess822.0 mess822_addr.0 mess822_date.0 mess822_fold.0 mess822_quote.0 mess822_token.0 mess822_when.0;
+ do
+ cp "$f" "$pkgdir/usr/man/cat3/$f"
+ chmod 644 "$pkgdir/usr/man/cat3/$f"
+ done
+
+ mkdir "$pkgdir/etc"
+ chmod 755 "$pkgdir/etc"
+ for f in leapsecs.dat;
+ do
+ cp "$f" "$pkgdir/etc/$f"
+ chmod 644 "$pkgdir/etc/$f"
+ done
+
+}
+
+# EOF
diff --git a/mess822-conf-cc.patch b/mess822-conf-cc.patch
new file mode 100644
index 000000000000..f29248327e1e
--- /dev/null
+++ b/mess822-conf-cc.patch
@@ -0,0 +1,7 @@
+--- mess822-0.58/conf-cc.orig 2013-11-23 08:45:32.039787076 +0100
++++ mess822-0.58/conf-cc 2013-11-23 08:45:49.210141421 +0100
+@@ -1,3 +1,3 @@
+-gcc -O2
++gcc -O2 -include errno.h
+
+ This will be used to compile .c files.