summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeanlint2023-09-21 16:13:07 +0800
committermeanlint2023-09-21 16:13:07 +0800
commitc66052499c84901c6c441bd2f4eccd3feaf0c2d9 (patch)
treec4fabeb2b73bb32d9bba0b80d946480ac34556e2
downloadaur-c66052499c84901c6c441bd2f4eccd3feaf0c2d9.tar.gz
update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c11b06c078f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = metacubexd-bin
+ pkgdesc = Clash.Meta Dashboard, The Official One, XD
+ pkgver = 1.100.1
+ pkgrel = 1
+ url = https://github.com/MetaCubeX/metacubexd
+ arch = any
+ license = MIT
+ optdepends = clash: A rule-based tunnel in Go
+ optdepends = sing-box: The universal proxy platform
+ optdepends = clash-meta: Another Clash Kernel by MetaCubeX
+ provides = metacubexd
+ conflicts = metacubexd
+ source = https://github.com/MetaCubeX/metacubexd/releases/download/v1.100.1/dist.zip
+ sha256sums = SKIP
+
+pkgname = metacubexd-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c5d3064b09e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: meanlint <meanlint@outlook.com>
+
+pkgname=metacubexd-bin
+_pkgname=metacubexd
+pkgver=1.100.1
+pkgrel=1
+pkgdesc='Clash.Meta Dashboard, The Official One, XD'
+arch=('any')
+_repo="MetaCubeX/${_pkgname}"
+url="https://github.com/${_repo}"
+license=('MIT')
+optdepends=('clash: A rule-based tunnel in Go'
+ 'sing-box: The universal proxy platform'
+ 'clash-meta: Another Clash Kernel by MetaCubeX')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("https://github.com/MetaCubeX/metacubexd/releases/download/v${pkgver}/dist.zip")
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}"/
+ find . -type d -exec install -vd "${pkgdir}"/usr/share/"${_pkgname}"/{} \;
+ find . -type f -exec install -vm 644 {} "${pkgdir}"/usr/share/"${_pkgname}"/{} \;
+}
+