summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2017-11-03 08:30:54 +0000
committerWill Handley2017-11-03 08:30:54 +0000
commit7dba1b639d8422f83da02bfc911cebdff8529349 (patch)
tree30bd0c21deb3765513771c4575a38856fc78321e
parent1610e6e24f50fee7bebc5bd0beda09fcfeba732a (diff)
downloadaur-7dba1b639d8422f83da02bfc911cebdff8529349.tar.gz
Better control of Wno-error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a66e1ea9f999..e55612b34eec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Oct 24 14:48:38 UTC 2017
+# Fri Nov 3 08:30:35 UTC 2017
pkgbase = metaio
pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. metaio
pkgver = 8.4.0
- pkgrel = 5
+ pkgrel = 6
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
arch = any
groups = lalsuite
diff --git a/PKGBUILD b/PKGBUILD
index 0693e6732b32..d9e334ffec27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=metaio
_pkgname=${pkgname}
pkgver=8.4.0
-pkgrel=5
+pkgrel=6
pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
arch=(any)
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
@@ -20,11 +20,10 @@ source=("http://software.ligo.org/lscsoft/source/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('8990d5aa23614328880d15af72071009a578cedf75174e437b3d63643b850b76')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- sed -i 's/\-Werror//g' configure
}
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure --prefix=${pkgdir}/usr CFLAGS=-O3
+ ./configure --prefix=${pkgdir}/usr CFLAGS='-O3 -Wno-error'
make -j
}
check() {