summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlrich Schreiner2020-05-18 17:56:43 +0200
committerUlrich Schreiner2020-05-18 17:56:43 +0200
commit71c546d0b35b35c455bdd0b0685168aa2c9b9aba (patch)
treee4de5b6e7c5d30f650ce0ceab7675cd368cdb310
parentb1dd4131c74f05e594fa98341127e8d41782ec1e (diff)
downloadaur-71c546d0b35b35c455bdd0b0685168aa2c9b9aba.tar.gz
update metalctl
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--Makefile5
-rw-r--r--PKGBUILD8
4 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f91b61706d4f..b9ebedbf973e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = metalctl-bin
pkgdesc = A command line tool for metal-stack services
- pkgver = 0.7.5
+ pkgver = 0.7.6
pkgrel = 1
url = https://github.com/metal-stack/metalctl
arch = x86_64
license = MIT
provides = metalctl
- source = https://github.com/metal-stack/metalctl/releases/download/v0.7.5/metalctl-linux-amd64
+ source = https://github.com/metal-stack/metalctl/releases/download/v0.7.6/metalctl-linux-amd64
md5sums = 30b6d834d6beaef7ae83cf2365b39bb2
pkgname = metalctl-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..225b1473921a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+metalctl-linux*
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..734c6c755b4e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,5 @@
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+integrity:
+ makepkg -g \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 395747df1d98..93f200bb9361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ulrich Schreiner <ulrich.schreiner@gmail.com>
pkgname=metalctl-bin
-pkgver=0.7.5
+pkgver=0.7.6
pkgrel=1
pkgdesc='A command line tool for metal-stack services'
url='https://github.com/metal-stack/metalctl'
@@ -9,14 +9,14 @@ license=('MIT')
arch=('x86_64')
provides=('metalctl')
source=("https://github.com/metal-stack/metalctl/releases/download/v$pkgver/metalctl-linux-amd64")
-md5sums=('30b6d834d6beaef7ae83cf2365b39bb2')
+md5sums=('03033965c7caaadc71d3e8f16b4139da')
package() {
install -Dm 755 "$srcdir/metalctl-linux-amd64" "$pkgdir/usr/bin/metalctl"
- # Populate bash, zsh, and fish completions
+ # Populate bash, zsh completions
install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
"$pkgdir/usr/bin/metalctl" completion > "$pkgdir/usr/share/bash-completion/completions/metalctl"
"$pkgdir/usr/bin/metalctl" zsh-completion > "$pkgdir/usr/share/zsh/site-functions/_metalctl"
-} \ No newline at end of file
+}