summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Abernethy2015-07-03 19:06:01 +0200
committerPhilip Abernethy2015-07-03 19:06:01 +0200
commit34f8650c034173ed4ac0ab1270df5bbe2deb9b39 (patch)
treeb8f06f73695f614cd377e5cffc25d0afde2bc475
downloadaur-34f8650c034173ed4ac0ab1270df5bbe2deb9b39.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..314ab9d5efb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = metalslug3
+ pkgdesc = Very hard sidescrolling platformer/shooter
+ pkgver = 2014_06_09
+ pkgrel = 2
+ url = http://www.snkplaymore.co.jp/us/games/steam/metalslug3/
+ arch = x86_64
+ arch = i686
+ license = custom:commercial
+ depends = sdl2
+ depends = sdl2_mixer
+ source = hib://MetalSlug3-Linux-2014-06-09.sh
+ sha512sums = af2a94bf49cf9ad515d98c08ea61248d7f53529f369d7002de567be4d6a0afe465906c4a3d0b8a30b968db76e22a90c585671e7105aee4205a2597239d111ccc
+
+pkgname = metalslug3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0a3d7836729
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Philip Abernethy<chais.z3r0@gmail.com>
+pkgname="metalslug3"
+pkgver="2014_06_09"
+pkgrel=2
+pkgdesc="Very hard sidescrolling platformer/shooter"
+arch=('x86_64' 'i686')
+url='http://www.snkplaymore.co.jp/us/games/steam/metalslug3/'
+license=('custom:commercial')
+depends=('sdl2' 'sdl2_mixer')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://MetalSlug3-Linux-${pkgver//_/-}.sh")
+sha512sums=("af2a94bf49cf9ad515d98c08ea61248d7f53529f369d7002de567be4d6a0afe465906c4a3d0b8a30b968db76e22a90c585671e7105aee4205a2597239d111ccc")
+
+package() {
+ mkdir -p ${pkgdir}/{opt,usr/{bin,share/applications}}
+ mv ${srcdir}/data/noarch ${pkgdir}/opt/${pkgname}
+ if [ "$CARCH" = "x86_64" ]; then
+ install -m 755 ${srcdir}/data/x86_64/MetalSlug3.bin.x86_64 ${pkgdir}/opt/${pkgname}/MetalSlug3.bin
+ else
+ install -m 755 ${srcdir}/data/x86/MetalSlug3.bin.x86 ${pkgdir}/opt/${pkgname}/MetalSlug3.bin
+ fi
+
+ ln -s /opt/${pkgname}/MetalSlug3.bin ${pkgdir}/usr/bin/${pkgname}
+ echo "[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Metal Slug 3
+GenericName=Metal Slug 3
+Comment=${pkgdesc}
+Icon=/opt/${pkgname}/icon.png
+Exec="/opt/${pkgname}/MetalSlug3.bin"
+Categories=Game;
+Path=/opt/${pkgname}" > ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}