summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott2023-07-07 23:20:30 -0700
committerScott2023-07-07 23:20:30 -0700
commit2a6563cb3c5fd717a0984f9148d863f253b85215 (patch)
treef26b136caf4cf2f3e476316f876c5d9951d3b91b
downloadaur-2a6563cb3c5fd717a0984f9148d863f253b85215.tar.gz
Initial commit
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3f117b56329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: zulc22 <zulc22db+oss@gmail.com>
+pkgname=metamorphose2-python3-git
+pkgver=r130.55ffc9f
+pkgrel=1
+pkgdesc="Updated fork of Métamorphose 2, by timinaust"
+arch=('any')
+url="https://github.com/timinaust/metamorphose2/tree/Python3_WXPython4"
+license=('GPL')
+groups=()
+depends=('python>=3.0' 'python<4.0' 'python-wxpython>=4.0' 'python-pillow>=2.3.0')
+makedepends=('git')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}" "metamorphose2" "metamorphose2-git")
+replaces=()
+backup=()
+options=()
+install=
+source=('metamorphose2::git+https://github.com/timinaust/metamorphose2#branch=Python3_WXPython4')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/metamorphose2"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/metamorphose2"
+ git submodule update --init
+}
+
+package() {
+ cd "$srcdir/metamorphose2"
+ make DESTDIR="$pkgdir/" all
+}