summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDino Morelli2024-01-18 10:01:52 -0500
committerDino Morelli2024-01-18 10:01:52 -0500
commite1a23996af0aadfae500eb0351a9a5536fdc8d62 (patch)
tree0ae0bf4e982cc51a5626fed5b8f00a934092ed7b
downloadaur-e1a23996af0aadfae500eb0351a9a5536fdc8d62.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd78e9e82ede
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = metar-display-bin
+ pkgdesc = Retrieve and parse METAR weather for display. Packaged upstream binaries.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/dino-/metar-display
+ arch = x86_64
+ license = ISC
+ depends = fuse2
+ depends = zlib
+ provides = metar-display
+ conflicts = metar-display
+ options = !strip
+ source = https://github.com/dino-/metar-display/releases/download/1.0/metar-display-1.0-x86_64.AppImage
+ sha256sums = 3566e9ab0e7f6cb7782f87f6aa6c8179eb0d8dd288d2f317863d5257d375e0d4
+
+pkgname = metar-display-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eddc286dcb58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dino Morelli <dino@ui3.info>
+
+pkgname=metar-display-bin
+_pkgname=metar-display
+pkgver=1.0
+pkgrel=1
+pkgdesc="Retrieve and parse METAR weather for display. Packaged upstream binaries."
+arch=('x86_64')
+url="https://github.com/dino-/${_pkgname}"
+license=('ISC')
+provides=(metar-display)
+conflicts=(metar-display)
+depends=(fuse2 zlib)
+makedepends=()
+# This software comes as an AppImage, auto-stripping by the AUR tools breaks it
+options=(!strip)
+_appimageFile="${_pkgname}-${pkgver}-${arch}.AppImage"
+source=("https://github.com/dino-/${_pkgname}/releases/download/${pkgver}/${_appimageFile}")
+sha256sums=('3566e9ab0e7f6cb7782f87f6aa6c8179eb0d8dd288d2f317863d5257d375e0d4')
+package() {
+ chmod +x "${_appimageFile}"
+ ./${_appimageFile} --appimage-extract usr/share/${_pkgname}/doc/LICENSE
+ install -m 755 -D "${_pkgname}-${pkgver}-${CARCH}.AppImage" "${pkgdir}/usr/bin/${_pkgname}"
+ install -m 644 -D "squashfs-root/usr/share/${_pkgname}/doc/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}