summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-03-04 12:08:45 +0100
committeranthraxx2016-03-04 12:08:45 +0100
commitb94bd74190d0fda54e4205fa422083f6a0819565 (patch)
treeea33fef50fc6dffe6e29a770eafc98dabcce8a4c
parentfba98d7c2a41ba9e6b2b6d65942838b34beb302c (diff)
downloadaur-b94bd74190d0fda54e4205fa422083f6a0819565.tar.gz
upgpkg: metasploit-git 4.11.12.37348.8b32f22-1
upstream release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--metasploit.install26
3 files changed, 14 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afdf2803fd11..ab6f876c1232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
+# Generated by mksrcinfo v8
+# Fri Mar 4 11:08:45 UTC 2016
pkgbase = metasploit-git
pkgdesc = An advanced open-source platform for developing, testing, and using exploit code
- pkgver = 4.11.4.34771.a611fff
+ pkgver = 4.11.12.37348.8b32f22
pkgrel = 1
epoch = 1
url = http://www.metasploit.com/
- install = metasploit.install
- arch = any
+ arch = i686
+ arch = x86_64
license = BSD
depends = ruby
depends = libpcap
diff --git a/PKGBUILD b/PKGBUILD
index 4f2282613d12..c03ebf1c775b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
# Contributor: al.janitor <al.janitor [at] sdf [dot] org>
pkgname=metasploit-git
-pkgver=4.11.4.34771.a611fff
+pkgver=4.11.12.37348.8b32f22
pkgrel=1
epoch=1
pkgdesc="An advanced open-source platform for developing, testing, and using exploit code"
url='http://www.metasploit.com/'
-arch=('any')
+arch=('i686' 'x86_64')
license=('BSD')
depends=('ruby' 'libpcap' 'postgresql-libs' 'ruby-bundler' 'sqlite' 'git')
optdepends=(
@@ -22,7 +22,6 @@ optdepends=(
provides=('metasploit')
conflicts=('metasploit')
options=('!strip')
-install="metasploit.install"
source=(${pkgname}::git+https://github.com/rapid7/metasploit-framework.git)
sha512sums=('SKIP')
@@ -34,6 +33,12 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
+build() {
+ cd ${pkgname}
+ bundle install -j"$(nproc)" --no-cache --deployment
+ find vendor/bundle/ruby/*/gems/robots-* -exec chmod o+r '{}' \;
+}
+
package() {
cd ${pkgname}
@@ -42,7 +47,7 @@ package() {
for f in "${pkgdir}"/opt/${pkgname}/msf*; do
local _msffile="${pkgdir}/usr/bin/`basename "${f}"`"
- echo "BUNDLE_GEMFILE=/opt/${pkgname}/Gemfile bundle exec ruby /opt/${pkgname}/`basename "${f}"` \"\$@\"" > ${_msffile}
+ echo -e "#!/bin/sh\nBUNDLE_GEMFILE=/opt/${pkgname}/Gemfile bundle exec ruby /opt/${pkgname}/`basename "${f}"` \"\$@\"" > ${_msffile}
chmod 755 ${_msffile}
done
diff --git a/metasploit.install b/metasploit.install
deleted file mode 100644
index 189247b1fddc..000000000000
--- a/metasploit.install
+++ /dev/null
@@ -1,26 +0,0 @@
-update_ruby_deps() {
- cd /opt/metasploit-git
- bundle install --path vendor/bundle
- find /opt/metasploit-git/vendor/bundle/ruby -name robots.rb -exec chmod o+r '{}' \;
-}
-
-
-post_install() {
- echo 'Installing necessary ruby dependencies with ruby-bundle'
- update_ruby_deps
-}
-
-
-post_upgrade() {
- echo 'Updating ruby dependencies with ruby-bundle'
- update_ruby_deps
-}
-
-post_remove() {
- echo 'Deleting metasploit folder to remove locally installed gems'
- # remove old location
- rm -rf /usr/share/metasploit-git
- rm -rf /opt/metasploit-git
-}
-
-# vim: ts=2 sw=2 et: