summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-09-30 14:35:09 -0600
committeryochananmarqos2019-09-30 14:35:09 -0600
commitd6dea3141d10283260e3a73d415c67a29f54eb5a (patch)
treeb9363e55b3de2deb750f86368f5f84f05ef6c639
parentd53c634b427c76fc11078d6764d3c9417796d198 (diff)
downloadaur-d6dea3141d10283260e3a73d415c67a29f54eb5a.tar.gz
updated to 0.9.8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bf237502d25..370fff896ecc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meteo-gtk
pkgdesc = A forecast application using OpenWeatherMap API
- pkgver = 0.9.7
- pkgrel = 5
+ pkgver = 0.9.8
+ pkgrel = 1
url = https://gitlab.com/bitseater/meteo
arch = any
license = GPL3
@@ -15,8 +15,8 @@ pkgbase = meteo-gtk
optdepends = gnome-shell-extension-appindicator
provides = meteo
conflicts = meteo
- source = meteo-gtk-0.9.7.tar.gz::https://gitlab.com/bitseater/meteo/-/archive/0.9.7/meteo-0.9.7.tar.gz
- sha256sums = 47594d2243691d0afe9b88118fe951c957f5787f2bf9db5ce27d35bed26691f9
+ source = meteo-gtk-0.9.8.tar.gz::https://gitlab.com/bitseater/meteo/-/archive/0.9.8/meteo-0.9.8.tar.gz
+ sha256sums = 22d8132e9c3bc62b3ec090275abd8b211d9d99b89812dc69e987cd315f898d0d
pkgname = meteo-gtk
diff --git a/PKGBUILD b/PKGBUILD
index 868e73032fac..03483aeb8fe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=meteo-gtk
-pkgver=0.9.7
-pkgrel=5
+pkgver=0.9.8
+pkgrel=1
pkgdesc="A forecast application using OpenWeatherMap API"
arch=('any')
url="https://gitlab.com/bitseater/meteo"
@@ -9,19 +9,19 @@ license=('GPL3')
depends=('gtk3' 'geocode-glib' 'webkit2gtk' 'libappindicator-gtk3')
makedepends=('meson' 'vala' 'appstream-glib')
optdepends=('gnome-shell-extension-appindicator')
-provides=('meteo')
-conflicts=('meteo')
-source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/bitseater/meteo/-/archive/$pkgver/meteo-$pkgver.tar.gz")
-sha256sums=('47594d2243691d0afe9b88118fe951c957f5787f2bf9db5ce27d35bed26691f9')
+provides=("${pkgname%-gtk}")
+conflicts=("${pkgname%-gtk}")
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/${pkgname%-gtk}-$pkgver.tar.gz")
+sha256sums=('22d8132e9c3bc62b3ec090275abd8b211d9d99b89812dc69e987cd315f898d0d')
build() {
- cd "meteo-$pkgver"
+ cd "${pkgname%-gtk}-$pkgver"
meson . build --prefix /usr
ninja -C build
}
package() {
- cd "meteo-$pkgver"
+ cd "${pkgname%-gtk}-$pkgver"
DESTDIR="$pkgdir" ninja -C build install
- ln -s /usr/bin/com.gitlab.bitseater.meteo $pkgdir/usr/bin/meteo
+ ln -s /usr/bin/com.gitlab.bitseater.meteo "$pkgdir/usr/bin/${pkgname%-gtk}"
}