summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Lanham2017-10-29 11:08:31 -0700
committerNick Lanham2017-10-29 11:08:31 -0700
commite11317275a683570aec3891e886f3e2ff6e9d0f7 (patch)
tree0e6c67b6c7a954bc020bc3db181e1914aa24a63d
downloadaur-meteocons.tar.gz
Initial commit, working PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--License.txt29
-rw-r--r--PKGBUILD29
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..288cb44ce3e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = meteocons
+ pkgdesc = A set of over 40 weather icons
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.alessioatzeni.com/meteocons/
+ arch = any
+ license = custom
+ depends = fontconfig
+ source = http://www.alessioatzeni.com/meteocons/res/download/meteocons-font.zip
+ source = License.txt
+ sha256sums = a9550332979f36a572ee0693ab1c07e44e47d5ac72c424f6db1e81cca2a1c74b
+ sha256sums = 7aa921e93c2849ddb4e1a383063bf23c81a9f1dd1aebd3674caceb061b51d104
+
+pkgname = ttf-meteocons
+
+pkgname = otf-meteocons
+
diff --git a/License.txt b/License.txt
new file mode 100644
index 000000000000..617483bc5f03
--- /dev/null
+++ b/License.txt
@@ -0,0 +1,29 @@
+Thank you for usign Meteocons!
+
+If you would like to be among the first ones to hear about all the news, follow @bluxart and @pyconic on Twitter.
+
+LICENSE:
+-------------------
+
+Meteocons are free for use in both personal and commercial projects.
+
+No attribution or backlinks are required, but any form of spreading the word is always appreciated!
+
+You must not resell any icons or distribute them in any other way.
+
+The Icons as such are the property of the author.
+
+Intellectual property rights are not transferred with the download of the icons.
+
+Alessio Atzeni
+
+Dont'miss my last project "Pyconic" http://www.pyconic.com
+768 Royalty-free vector icons, raster and font formats. When Pyconic launch 400 PNG Free Icons at 32px for your trouble. :)
+
+CONTACT:
+-------------------
+Web: http://www.alessioatzeni.com
+Email: info@alessioatzeni.com
+Twitter: http://twitter.com/bluxart
+Twitter: http://twitter.com/pyconic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c720751508a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nick Lanham <nickl@berkeley.edu>
+
+pkgbase=meteocons
+pkgname=(ttf-meteocons otf-meteocons)
+pkgver=1.0
+pkgrel=1
+pkgdesc="A set of over 40 weather icons"
+url="http://www.alessioatzeni.com/meteocons/"
+license=('custom')
+arch=('any')
+depends=('fontconfig')
+source=("http://www.alessioatzeni.com/meteocons/res/download/meteocons-font.zip"
+ "License.txt")
+sha256sums=('a9550332979f36a572ee0693ab1c07e44e47d5ac72c424f6db1e81cca2a1c74b'
+ '7aa921e93c2849ddb4e1a383063bf23c81a9f1dd1aebd3674caceb061b51d104')
+
+package_ttf-meteocons() {
+ install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ cd "meteocons-font/FONT/Desktop-font"
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -m644 *.ttf "$pkgdir/usr/share/fonts/TTF"
+}
+
+package_otf-meteocons() {
+ install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/License.txt"
+ cd "meteocons-font/FONT/Desktop-font"
+ install -d "$pkgdir/usr/share/fonts/OTF"
+ install -m644 *.otf "$pkgdir/usr/share/fonts/OTF"
+}