summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2018-11-20 17:30:42 +0100
committerSimon Legner2018-11-20 17:31:16 +0100
commit7b88cf91a54eab3ac2c88d85768a5d28d8634d4f (patch)
treeefdb1f20fa22124a1067959e6f481c24056de1ba
downloadaur-7b88cf91a54eab3ac2c88d85768a5d28d8634d4f.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c91c252df9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = meteoio
+ pkgdesc = Make data access easy and safe for numerical simulations in environmental sciences
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://models.slf.ch/p/meteoio/
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ optdepends = doxygen: documentation
+ source = https://models.slf.ch/p/meteoio/downloads/get/MeteoIO-2.7.0-src.tar.gz
+ sha256sums = 4e5e141c7d56f18b79644116337775c03648e3e011bc1f30bee657afc63fe3ba
+
+pkgname = meteoio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ccdd6acb5ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=meteoio
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="Make data access easy and safe for numerical simulations in environmental sciences"
+arch=('x86_64')
+url="https://models.slf.ch/p/meteoio/"
+license=('LGPL3')
+makedepends=('cmake')
+optdepends=('doxygen: documentation')
+source=("https://models.slf.ch/p/meteoio/downloads/get/MeteoIO-$pkgver-src.tar.gz")
+
+build() {
+ cd "MeteoIO-$pkgver-src"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "MeteoIO-$pkgver-src/build"
+ make DESTDIR="$pkgdir/" install
+}
+
+sha256sums=('4e5e141c7d56f18b79644116337775c03648e3e011bc1f30bee657afc63fe3ba')