summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2022-01-26 15:03:33 +0300
committerViktor Drobot2022-01-26 15:03:33 +0300
commit13ea740f9c5352ff38e098ac9c434c4a3b804c23 (patch)
tree045f86e648704cd7c5d070d145ef824f283b4cf5
parenta68fd74b667820e49ca4e9a8e82eeebe63d036d3 (diff)
downloadaur-13ea740f9c5352ff38e098ac9c434c4a3b804c23.tar.gz
Fix archs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 051a68cfce61..d63b2f660c42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = meteor-decode-git
pkgdesc = Meteor-M2 LRPT decoder
- pkgver = r50.d1e317c
+ pkgver = r66.e7ca456
pkgrel = 1
url = https://github.com/dbdexter-dev/meteor_decode
- arch = any
+ arch = i686
+ arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
@@ -14,4 +15,3 @@ pkgbase = meteor-decode-git
sha256sums = SKIP
pkgname = meteor-decode-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bfb733adccfa..08990cc21c19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=meteor-decode-git
-pkgver=r50.d1e317c
+pkgver=r66.e7ca456
pkgrel=1
pkgdesc="Meteor-M2 LRPT decoder"
-arch=(any)
+arch=(i686 x86_64)
license=(MIT)
url="https://github.com/dbdexter-dev/meteor_decode"
depends=(libpng)
makedepends=(git cmake)
provides=(meteor-decode)
conflicts=(meteor-decode)
-source=("$pkgname::git+https://github.com/dbdexter-dev/meteor_decode.git")
+source=("${pkgname}::git+https://github.com/dbdexter-dev/meteor_decode.git")
sha256sums=('SKIP')
pkgver() {
cd "${pkgname}"
+
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}