summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-08-25 13:48:57 +0300
committerDrobot Viktor2019-08-25 13:48:57 +0300
commitacaca10aed3f6c732a2092bdbeb0bde387e739ea (patch)
tree315e5e70c1c75da0c264af0ceebc123d8762a468
downloadaur-acaca10aed3f6c732a2092bdbeb0bde387e739ea.tar.gz
First release
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fe2cd3fafe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = meteor-rectify-git
+ pkgdesc = Meteor-M2 image rectifier
+ pkgver = r5.fbab338
+ pkgrel = 1
+ url = https://github.com/dbdexter-dev/meteor_rectify
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-pillow
+ depends = python-numpy
+ provides = meteor-rectify
+ conflicts = meteor-rectify
+ source = meteor-rectify-git::git+https://github.com/dbdexter-dev/meteor_rectify.git
+ sha1sums = SKIP
+
+pkgname = meteor-rectify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe4011717aa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=meteor-rectify-git
+pkgver=r5.fbab338
+pkgrel=1
+pkgdesc="Meteor-M2 image rectifier "
+arch=(any)
+license=('MIT')
+url="https://github.com/dbdexter-dev/meteor_rectify"
+depends=('python' 'python-pillow' 'python-numpy')
+makedepends=('git')
+provides=('meteor-rectify')
+conflicts=('meteor-rectify')
+source=("$pkgname::git+https://github.com/dbdexter-dev/meteor_rectify.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm755 rectify.py ${pkgdir}/usr/bin/meteor-rectify
+}